#20 PerlQT not working on new Cygwin

closed-fixed
None
5
2003-10-06
2003-06-02
Jondice
No

I have installed QT3 and KDE3 for a recent version of
Cygwin (most recent as of this writing), but I can't
get PerlQT to work correctly. The binary version of
PerlQT that has been packaged for Cygwin was made for
an older version of Perl and compiled with older
libraries, which may be the problem. It complains that
it isn't able to load Qt.dll.

I'm trying to install from source now, but I'm having
issues with getting the configure script to recognize
my Qt installation (version 3.04 provided by
kde-cygwin.sourceforge.net). I'd appreciate a response
on what you think as soon as possible even if the
problem isn't completely solved.

Thanks,
Brandon Barker

Discussion

  • Jondice
    Jondice
    2003-06-02

    • priority: 5 --> 9
    • assigned_to: nobody --> germaingarand
     
  • germain garand
    germain garand
    2003-06-03

    • priority: 9 --> 5
    • status: open --> open-later
     
  • germain garand
    germain garand
    2003-06-03

    Logged In: YES
    user_id=145773

    Hi,
    I'm aware of current default Cygwin packages versions.

    However, building a new package for Cygwin is non-trivial, experimental,
    involves quite some manual work, and isn't worth the time/effort since the
    upcoming PerlQt 3.008 is scheduled for within two weeks.

    In the meantime, you may simply downgrade your Perl package from the
    cygwin installer (chose version 5.6.1 from the dropdown list). If you do
    have a Qt-3.04 installed, it ought to run fine.

    Regards,
    Germain Garand

     
  • germain garand
    germain garand
    2003-10-06

    • status: open-later --> closed-later
     
  • germain garand
    germain garand
    2003-10-06

    • status: closed-later --> closed-fixed