You need to install the debugging tools for Windows: http://www.microsoft.com/whdc/devtools/debugging/installx86.mspx
After they are installed, ensure that you have set up a path to include those debuggin tools, including symchk.exe, for example,
set path=C:\Program Files\Debugging Tools for Windows;%path%

Then rerun tinstall and follow its directions. [I did need to manually run ddr and ddi after it finally was able to download the symbols]

Frank
-----------------
Frank Levine
Senior Programmer
Austin, TX
levinef@us.ibm.com
512-286-7213



"Marco" <shrewdcat@msn.com>

07/22/2009 03:49 AM

To
<perfinsp-list@lists.sourceforge.net>
cc
Subject
[Perfinsp-list] Tools will install but will run in Limited Function        mode





***** Running on Microsoft Windows Vista (v6.0), Build 6002, SP2 *****
 
*********************************************************************
**  WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  **
*********************************************************************
**      ----------------------------------------------------       **
**       KERNEL NOT FOUND/RECOGNIZED FOR FULL FUNCTION MODE        **
**      ----------------------------------------------------       **
**                                                                 **
**    Tools will install but will run in Limited Function mode.    **
**    *********************************************************    **
**                                                                 **
** Possible problems are:                                          **
** - Unable to locate file kerneldb-vista.bin in symtools directory.  *
** - Unable to identify running kernel (signature not in           **
**   kerneldb-vista.bin file).                                        *
**                                                                 **
** Unable to resolve IP address for msdl.microsoft.com. Cannot     **
** attempt to automatically restore Full Function mode.            **
**                                                                 **
** To manually attempt to restore Full Function mode:              **
** --------------------------------------------------              **
** 1) Change to the 'symtools' directory.                          **
** 2) Run SPUPDATE.                                                **
** 3) Change back to the 'bin' directory.                          **
** 4) Re-run TINSTALL.                                             **
**                                                                 **
** If the problem persists (kernel not recognized) please save     **
** a copy of the tinstall screen output and contact a member of      **
** of the tools group for further assistance.                      **
**                                                                 **
*********************************************************************
**  WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  WARNING  **
*********************************************************************

 
After that, i tried to do as "To manually attempt to restore Full Function mode" steps, but error info got as below:
 
>> spupdate v1.0.9 for x86
***** Running on Microsoft Windows Vista (v6.0), Build 6002, SP2 *****
*E* Unable to find symchk.exe. Make sure PATH is set correctly.
* You must have a path to Microsoft Debugging Tools at version 6.4.7.0 or a
.

 
Can you tell me how to fix this problem?  Tks a lot.------------------------------------------------------------------------------
_______________________________________________
Perfinsp-list mailing list
Perfinsp-list@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/perfinsp-list