Hi Maynard,

Sure, will do that.
We need to upgrade the pitrace driver to work with the newer kernels anyway.

Regards,


Milena Milenkovic, PhD
WebSphere BPM & C Performance Tools
mmilenko@us.ibm.com



maynardj@linux.vnet.ibm.com

10/09/2008 11:38 AM

To
perfinsp-list@lists.sourceforge.net
cc
Subject
[Perfinsp-list] Need to support changes in recent kernel version





Hello,
In our present effort to upgrade the ITrace package for SLES 11, the Novell guy I'm working with has brought to my attention some changes needed in Performance Inspector code to support the kernel version used in SLES 11 -- i.e., 2.6.27.  For example, on_each_cpu only has two parameters now, instead of 3; and the nopage API has been removed (replaced, I think, with "fault").

I will work on some patches that are needed for 2.6.27 and post them to this list.  Then, can you determine how to integrate them into the source (i.e., how to conditionally compile, based on kernel version)?

Thanks.
-Maynard



-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Perfinsp-list mailing list
Perfinsp-list@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/perfinsp-list