How it works in OpenSuSE 12.3

2013-05-13
2013-05-13
  • ./configure \ --prefix= \ --mandir=/usr/share/man \ --datadir=/usr/share \ --sysconfdir=/etc \ --localstatedir=/var \ --with-lsb=/lib/lsb/init-functions \ --enable-cron \ --enable-dbus \ --enable-logrotate \ --enable-networkmanager \ --enable-zlib \ --with-qt4 \ --disable-lowmem

    make

    sudo make install

    The pgl service appears automatically among the Services (visible in Yast), but it is disabled by default.

    The pgld works, and pglgui works, but not entirely. When I change configuration of lists, it fails to execute commands in KDE. I then have to execute commands in console manually:

    sudo sh /tmp/execute-all-pgl-commands.sh
    sudo /bin/pglcmd reload

    then it works again.

    Also, the program seems silly if you cannot configure it to allow http traffic. For example, free online courses site coursera.org is blocked as a "primary threat", so its ridiculous.

     
  • jre-phoenix
    jre-phoenix
    2013-05-13

    Hi, many thanks for your report.

    To execute commands in KDE try to change the sudo frontend (pglgui: Options - Settings), e.g. /usr/bin/kdesudo or /usr/bin/kdesu. You may also start pglgui and check its output there to spot any error messages.

    To allow http traffic go to Configure - Whitelist - Add (the green "+" sign). In the dialog "Add a Custom exception" verify that Port, Outgoing and TCP are checked/ticked, then write e.g. http or 80 and click OK, then Apply. Of course you can also do this in /etc/pgl/pglcmd.conf (WHITE_TCP_OUT="80").

    Have fun and report back if everything works. We may seem silly, but we try hard not to be silly :)
    (Still we don't have any influence on what's in the blocklists, you'd have to contact their respective maintainers for that.)

    Greets
    jre