#31 Could not import pdfshuffler

open
nobody
None
5
2012-04-17
2012-04-17
rosc2112
No

I'm about to kick python-poppler in the nuts. Apparently this pile of cruft is no longer actively supported so I figured I'd post the error here in the hope someone might be able to help me get pdfshuffler working again.

I got pypoppler compiled, after finding patches for it in the ubuntu repositories. Ok, so far so good. But, now apparently pypoppler builds its lib without gdk when somehow it needs it. I get this error trying to run pdfshuffler:

Error: Could not import pdfshuffler
Cause: /usr/lib/python2.7/site-packages/poppler.so: undefined symbol: gdk_region_copy

Any clues for me?

Discussion