#13 win2k: LINES value must be >=2 and <=244

closed-wont-fix
None
5
2007-05-14
2002-06-10
Anonymous
No

hi,

i compiled pdcurses with the current version of cygwin
(make -f gccwin32.mak all) but when i try to run xmas i get the
following error:
LINES value must be &gt;=2 and &lt;=244; got
1
initscr(): LINES=1 COLS=1: too small

any
ideas?
thanks

Discussion

  • Logged In: NO

    unset your CYGWIN environment variable and your problem is
    solved.

    cheers

     
  • Mark Hessling
    Mark Hessling
    2002-10-28

    • status: open --> closed
     
  • Mark Hessling
    Mark Hessling
    2002-10-28

    Logged In: YES
    user_id=86185

    Just tested this (and I don't have a CYGWIN env variable) and
    it worked.

     
    • summary: win2k: LINES value must be >=2 and <=244 --> win2k: LINES value must be >=2 and <=244
     
    • assigned_to: nobody --> wmcbrine
    • status: closed --> closed-wont-fix
     
  • Logged In: YES
    user_id=27933
    Originator: NO

    This is a symptom of trying to run it in an xterm, or any terminal other than the Windows console. PDCurses works at the level of console API calls, and isn't compatible with other terminals. The error message could stand to be more informative, though.