#17 config dialog box is too big to fit in a 1280x768 resolution

open
nobody
None
5
2010-05-15
2009-10-02
Wei Mingzhi
No

running PCSX-df with a screen resolution of 1280x768 will result in the config dialog box not shown completely, as in this screenshot:
http://i3.6.cn/cvbnm/8c/33/56/839426d86a9e6ff0b8f7fd0d6a9b6467.jpg

Discussion

  • Andrew Burton
    Andrew Burton
    2009-11-16

    Fixed by moving the options to an Expander. Not the ideal solution - are those options actually relevant/useful anymore, is there a way to avoid making the user have to manage these options?

     
  • Andrew Burton
    Andrew Burton
    2009-11-16

    • status: open --> closed-fixed
     
  • Wei Mingzhi
    Wei Mingzhi
    2010-05-15

    this is not fully fixed anyways :)

    it's still looks problematic after clicking on "Advanced Options" (I know I can click the expander again but it's definately does not look best). Maybe stuffing the options into GtkNotebook can be a better idea (similar thing is done in pcsx2 0.9.7 preferences window I think).

     
  • Wei Mingzhi
    Wei Mingzhi
    2010-05-15

    • status: closed-fixed --> open
     
  • Wei Mingzhi
    Wei Mingzhi
    2010-05-15

    > is there a way to avoid making the user have to manage these options?
    for those gamefix options, I don't think so except enumerating every games (which is too much work)...
    options like "SIO IRQ Always Enabled" are used to pass a certain crash/freeze point caused by SIO timing inaccuracy, and should only be enabled at the crash/freeze point.
    and some other options (such as showing console messages, B&W movie, disable CDDA/XA Audio, etc.) are at user's choice I think.

    speaking of pcsx2 - those nice icons in pcsx2 svn definately worth stealing btw :)

     
  • Andrew Burton
    Andrew Burton
    2010-05-17

    SIO IRQ definitely sounds like a developer option, as does Console Output, Enable Debugger... a separate Developer Preferences dialog maybe?

    B&W movie and disable CDDA/XA audio sound like ways to speed up emulation on slower PCs - correct? If so, they were probably valid 3-4 years ago but given today's PCs may not be required anymore?

    I'm always looking at ways of cutting back unnecessary options ;)