#238 to high depends on configure and compilation


i compile and package venenux release of pcmanfm with valac 0.12 and glib 2.24, but configure said must be valac 0.13 as minimun and glib 2.26 (wich depends on gobject-2.0 2.26 +)

i revised before compiled, code and in libfm theres no lines for gobject instrocpection,an valac its only used for stupid thing, so i suggest for LIGHT DEKSTOP (that its only usefully in older machines thaaattt dont have too high software installled) reduce and modified code..

i think developer use windoze like distributions that install too high software for "light" dekstop.. and the autotools generate unused depdns (obviously produced by valac release instaled)

so before send this report i test enough the binaries and works as well, and problems i found are not related to valac or gobject (that its not used for any runtime operation of course hum)

as i said:

there's no fun in a light desktop (software) if required a high dektops (hardware)...


1 2 3 > >> (Page 1 of 3)
    • labels: 805537 -->
  • Thank you very much for the testing. You're talking not about old hardware but about old software instead. If newer software doesn't work on old hardware then it should be fixed but you're pointing at old enough software. And it's not next generation (thinking of introspection mentioned by you, which is gtk-3.0 feature) of the library but the same just old. And you know, another version of glib can give weirdness even if it could compile without warnings (which, BTW, can be checked if configured with --enable-debug and looked for any warnings - it shouldn't give any except some from vala).

  • Try to explain my point, and of many people in latin american and other minor country (like african people or taiwan) because otherwise there is no sense to use lightweight software :

    If my system requires very high dependences, these obviously by law (in a great majority of cases) will require more hardware! Understand at last?

    as i said: there's no fun in a light desktop (software) if required a high dektops (hardware)...

    however, I discovered many segfaults if not compiling against glib 2.26 as a minimum, and 0.13 vala as minimun, and i cannot instance more than one filemanager threath in this cases..

    over leading the development, I doubt that in the future and interested in using pcmanfm as "light version" and may not be compiled on old desks, as these are what are on old machines ..

    my desire for a recent pcmanfm is because the tree side panel, and desktop management are essential, I have been waiting in hopes a recent version with support for tree and links on the desktop .. but I'll end up using razorqt that compiles with older software (already installed on older machines)

    I hope common sense empire and take into us, account users who do not use windo .. because it seems that this its just like Microsoft, more and more requirements ..

  • I'm sorry but I cannot see the point in not using just a bit less expired version of glib. You mean if you install a bit more recent version of library it will take another dependencies which are resource expensive for your hardware? I'm not talking about high version (i.e. gtk-3.0) but about the same gtk-2.0 but a bit updated. Or is it too hard to update glib in your configuration?

  • u cant understand? men! i updated from 2.16 to 2.22, and again to 2.24 and again now to 2.26 the glib???????? !!!!

    i cant standt in upgrades always! i just only want to compile a pcmanfm.. theres no sence in constants upgrades (like mocosoft)

    "a bit updated" like winbuntu ? always updates and updates?

    a pemtium3 with 128 ram runs lxde and pcmanfm perfectly but in 2 years not with gtk+ 2.22 and glib 2.26 runs "a bit" slower" men understant that!

  • Ah, I see. OK, we'll check what we can do to let it work well with older glib too. Thank you.

  • i glad to see u pay attentio to this, thanks for that.. my hope and the hope of many are on us..

  • I've tested version 1.0.1-beta with gtk+ 2.20 and glib 2.24. It should be configured with --disable-actions though to disable vala-related things and it works fine then. That version is in the branch and will be in master branch after 1.0 is released. If you're desperate to test then you can get libfm with:

    git clone git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/libfm
    cd libfm
    git checkout 1.0.1-beta

    pcmanfm you can get with:

    git clone git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm
    cd pcmanfm
    git checkout 1.0.1-beta-fixes

    Use instructions on the wiki how to compile it from the Git code.

  • now cloning and testing, if work i mantaint a clone in github.. for testing purposes and packagin..

1 2 3 > >> (Page 1 of 3)