Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#862 custom context menu entries from plugins are not applied to the folder menu

1.2
closed-fixed
pcmanfm (113)
5
2014-05-04
2014-04-22
Sworddragon
No

I'm using PCManFM 1.2.0 and normally on making a right click on a directory all entries associated to the mime type inode/directory are listed in the context menu but if in the current directory a right click on an empty place is made the context menu does not list these items.

Discussion

    • status: open --> closed-rejected
    • assigned_to: Lonely Stranger
     
  • Thank you for noticing this. This is an intended behavior, the folder is generally a very different entity than its contents, the same goes with any other application including other file managers. And context menu plugins have different handlers for folder and items as well.

     
  • Sworddragon
    Sworddragon
    2014-05-01

    I have created this ticket because of this:

    Ah, I see, you found a bug that menu is not updated appropriately for folder and therefore 'Open as Root' isn't shown for folder itself. It should've been shown. That bug should be filed then, not this 'sudo' thing. Thank you very much.

    Or was you meaning something else?

     
    • labels: --> pcmanfm
    • summary: inode/directory context menu entries are not applied to the current directory --> custom context menu entries from plugins are not applied to the folder menu
    • status: closed-rejected --> open
     
  • All I said is that menu for item in folder (which you mentioned in your request: "the context menu does not list these items" so I understood you wanted context menu similar to one you get for folder as item in view) is irrelevant to menu for folder.

    If you wanted to file mentioned bug you had to exactly mention that custom menu item (from DES-EMA action or from plugin) isn't shown in context menu for folder. OK, I change your report subject then so it'll be not ambiguous.

    Thank you.

     
  • Sworddragon
    Sworddragon
    2014-05-01

    In this case I'm not sure what you are mentioning about. After you said that I have found a bug I thought it was the missing context menu. Well, at least if I'm able to open the current directory as root with a user defined desktop file I'm fine with this.

     
    • status: open --> closed-fixed
     
  • I hope this issue is completely fixed in current GIT repository. Check it when possible, please. Thank you very much.