#857 PCManFM indirectly hangs

1.2
closed-later
None
7
2015-05-19
2014-04-01
Sworddragon
No

I'm using PCManFM 1.2.0 and sometimes if I'm executing "sudo pcmanfm" the most parts of PCManFM will hang. For example I can't navigate into another directory or make somethig in the current directory but making a right click will still open the context menu and I can also close the window. I have made a look with gdb but nothing crashes so there is no backtrace. But I will still attach the log for the case it could help in some way.

1 Attachments

Discussion

  • You should not run graphic applications under sudo, use appropriate application to raise rights such as gksu or whatever you have. Read http://wiki.lxde.org/en/PCManFM for examples. Thank you very much.

     
  • Sworddragon
    Sworddragon
    2014-04-19

    Even if gksu is recommended I'm not seeing why sudo should not work. Also that sudo is the most times working but rarely not implies that there is still somewhere a bug hiding.

     
    • status: open --> closed-invalid
    • assigned_to: Lonely Stranger
     
  • I suppose it's because sudo doesn't handle ownership of X connections so despite it works sometimes, using it is still invalid. Use gksu/gksudo/beesu/whatever, please.

     
  • Sworddragon
    Sworddragon
    2014-04-19

    Well, PCManFM has removed the option to open the current directory as root so I switched into opening a terminal and using sudo. The change from PCManFM 1.1 to 1.2 in this case was just a heavy hit in usability for me. Currently I have 2 ways to solve this issue:

    • Looking for a solution that gives me back the usability.
    • Testing if the bug does appear on gksu too to have the chance it getting fixed for sudo too.

    But currently I have no motivation to do any of this. Sometimes I wished things in Linux would just be as simple as on Windows.

     
    Last edit: Sworddragon 2014-04-19
  • Luckily for you the solution is described long time ago in the mentioned Wiki page, as I said you in the very first comment. Read it and enjoy. Cheers!

     
  • Sworddragon
    Sworddragon
    2014-04-19

    If you mean the part with the desktop file: This solution does have the problem that you can not easily open the current directory without going a directory up (which is also not possible on / anymore). If you mean something else: I will make later a deeper look into the wiki page as I'm already too tired.

     
    Last edit: Sworddragon 2014-04-19
  • Ah, I see, you found a bug that menu is not updated appropriately for folder and therefore 'Open as Root' isn't shown for folder itself. It should've been shown. That bug should be filed then, not this 'sudo' thing. Thank you very much.

     
  • Sworddragon
    Sworddragon
    2014-04-22

    After making some tests with gksu I noticed that the hanging appeared there too.

     
    Last edit: Sworddragon 2014-04-22
  • Sworddragon
    Sworddragon
    2014-05-03

    I'm noticing that this bug also happens on the initial instance of PCManFM. Currently on my system I can always reproduce it with opening PCManFM, going up to / and then navigating down to /var/log/upstart, creating a new tab and then hitting the home button. After this PCManFM freezes partly as described in the startpost.

     
  • Could you give me list of folders in which described behavior is revealed? I'll try to reproduce it. Thank you very much.

     
    • status: closed-invalid --> open
    • Priority: 5 --> 7
     
  • Sworddragon
    Sworddragon
    2014-05-17

    Here are the reproduction steps:

    1. Open PCManFM.
    2. Go up to / and then down to /var.
    3. Create a new tab.
    4. Click the home button.

    After this PCManFM hangs. In the attachments is my configuration of LibFM and PCManFM (dir-settings.conf is empty) and a video how the bug looks just in case you can't reproduce it.

     
    Last edit: Sworddragon 2014-05-17
  • Unfortunately I still cannot reproduce it, even with your configs and using exactly your steps. I have no idea what's wrong with it. :(

     
  • Sworddragon
    Sworddragon
    2014-05-17

    Hm, this is really a difficult bug. It appears also on subdirectories of /var, even if they are empty. But for example /tmp is working fine so maybe the name has something to do with it. Also on checking this again I'm noticing that the tab is named "..." if it hangs. Have you maybe an idea how to debug this more?

     
    Last edit: Sworddragon 2014-05-17
  • Sworddragon
    Sworddragon
    2014-05-17

    I have made a fast gdb run without compiling PCManFM. If the output is not enough I will compile the debug version.

     
    Attachments
  • Unfortunately it seems to hang inside of gtk and I don't see what I can do with it, it may be some glib/gtk regression. Can you tell me exact versions of glib2 and gtk2 you are using? It would be good if you could test if this issue happens with some older glib/gtk versions too. And also I would like if you could test it with another sidebar view (i.e. Places). Thank you very much.

     
  • Sworddragon
    Sworddragon
    2014-06-09

    Can you tell me exact versions of glib2 and gtk2 you are using?

    I'm using GLib 2.40.0 and GTK 2.24.23. After testing a little I have figured out that downgrading GTK to version 2.24.20 from Ubuntu Saucy fixes the issue.

    And also I would like if you could test it with another sidebar view (i.e. Places).

    Using the bugged version of GTK2 and side_pane_mode=places does solve the issue too.

     
  • So it appear to be regression bug in GTK+ then. And they changed windows update between 2.24.20 and 2.24.23, that probably causes this. If you wouldn't report the bug to the GNOME bugzilla then let me know and I do that. Thank you very much.

     
    • status: open --> closed-later
     
  • I close this bug for now since I see nothing I can do with it, I'm sorry. Let hope GTK+ fixes the issue, or may be it's already fixed in 2.24.28.