#844 1.2.0 under Lubuntu 12.04

1.2
pending
nobody
None
5
2015-06-06
2014-03-06
ozpos
No

Hi all, Sorry in advance if this is not a bug.

I have been using Lubuntu 12.04 since its release and after trying 13.10 I liked the search facility in the new fm 1.2.0. I installed 1.2.0 under Lubuntu 12.04 but there is no search menu item under tools.

Is there anything I can do to rectify this ?

Discussion

  • ozpos
    ozpos
    2014-03-06

    Hi again, I have just noticed that search is available in tools if the current user is root.

    How can I enable search for other users/groups ?

     
  • I'm afraid you have more than one pcmanfm installed because it can be absend only in two cases: 1) it is older than 1.0.2; 2) it is linked with libfm older than 1.0.2. The uid does not affect menu at all.

     
  • ozpos
    ozpos
    2014-03-07

    Thank you for the reply. I did not build it locally so I guess it must be 1).

    Could anyone tell me how I find the earlier version and uninstall it ?

     
  • Sworddragon
    Sworddragon
    2014-03-08

    You could temporary enable the trusty repository with copying /etc/apt/sources.list to /etc/apt/sources.list.d/trusty.list and replacing all occurrences of precise with trusty in /etc/apt/sources.list.d/trusty.list. Now from a terminal run "sudo apt-get update && sudo apt-get install pcmanfm libfm4 libfm3-". If there is no dependency failure and if the solution is fine for you just confirm with pressing enter. After logout and login into your desktop the new version of PCManFM should be active. You can check this if Help -> About says you are using PCManFM 1.2.0 with LibFM 1.2.0. If all succeeded you can then delete /etc/apt/sources.list.d/trusty.list.

     
    Last edit: Sworddragon 2014-03-08
  • @sworddragon: invalid suggestion. Install any package from trusty into 12.04 will bring up replacement of everything (i.e. upgrade all the system to trusty) due to dependencies on newest packages. The pcmanfm and libfm should be built exactly in precise environment to be able to be installed without upgrading all the system.

    @ozpos: how you did install libfm and pcmanfm 1.2.0 into your 12.04? Did you use PPA lubuntu-dev for that?

     
  • Sworddragon
    Sworddragon
    2014-03-08

    Install any package from trusty into 12.04 will bring up replacement of everything (i.e. upgrade all the system to trusty) due to dependencies on newest packages.

    Normally there are no critical dependencies so the system shouldn't get upgraded. For example if I'm downgrading pcmanfm from trusty to precise only pcmanfm gets replaced and libfm-gtk-bin, libfm-gtk3 and libfm3 needs to be installed to have a valid system.

     
  • You are wrong. Downgrading is another issue, because dependencies aren't exact in most of cases but some condition (equal or newer), and package glib 2.39.91 in trusty will satisfy the contition >= 2.31.8 for libfm1 in precise (in downgrade case)but glib 2.32.1 in precise will not satisfy the condition >= 2.37.3 for libfm4 in trusty (in upgrade case). Therefore libglib will be upgraded, that will bring libc upgrade as well, and kernel upgrade, and all the dependent packages upgrade - usually it means 30% to 90% to be upgraded. For example, when I tried to install libfm3 built for debian unstable into debian wheezy 3 months later it was released (not 2 years as it is for precise) I was asked to upgrade 20% of the packages due to conflicts.

     
    Last edit: Lonely Stranger 2014-03-08
  • Sworddragon
    Sworddragon
    2014-03-08

    It seems I have made a little mistake on the downgrade with targeting the wrong version. Anyways:

    You are wrong.

    Not really because I have already hinted that some more packages could be installed: "If there is no dependency failure and if the solution is fine for you just confirm with pressing enter.". And yes, there can be differences on down- and upgrading but I have hinted this too: "Normally"

     
    Last edit: Sworddragon 2014-03-08
  • @ozpos: I'm still waiting your answer. Thanks.

     
    • status: open --> pending
     
  • Andreas E
    Andreas E
    2014-10-08

    Thank you for the reply. I did not build it locally so I guess it must be 1).

    Instead of blind guessing, it is also possible to check things directly, like this:

    $ ldd -v /usr/bin/pcmanfm | grep libfm

    The integer number X of the 'so.X' might already give an indication about an outdated shared object file installed if it is lower than usual.

     
    Last edit: Andreas E 2014-10-08
  • Well, about libfm used you can see its version in the 'About' dialog, it shows both versions - for pcmanfm and libfm, in case both are at least 1.2.0.

    If version of libfm is shown there then it might be another issue - modules aren't accessible. That can be checked by inspecting if file /usr/lib/x86_64-linux-gnu/libfm/modules/vfs-search.so is accessible from your user.

    If version of libfm isn't shown then it is simply old so just upgrade both pcmanfm and libfm-modules packages using PPA, please, they are available for Lubuntu 12.04.

     
  • Andreas E
    Andreas E
    2015-06-06

    12.04 LOL. Should the reporter still be running this version, I'd say it's about time to upgrade. I am at 15.04 aka Vivid now ;) (even 14.x would be OK, but 12.x??)

     
    Last edit: Andreas E 2015-06-06
    • Why not? I still use 11.10 on my workstation, with few packages upgraded, it works fine enough. :)