#770 Symlink is not shown #2

1.2
closed-wont-fix
5
2014-01-04
2013-08-14
Sworddragon
No

I'm using PCManFM 1.1.2 and while the "combination" od the old report is fixed (https://sourceforge.net/tracker/?func=detail&aid=3591771&group_id=156956&atid=801864) I have found a new one:

1. Open PCManFM and navigate to /tmp.
2. Open a terminal from PCManFM and execute "ln -s . test".
3. With PCManFM navigate into test.
4. Click on the directory-up button.
5. Click on test.
6. Press del.
7. Switch to the already opened terminal and execute "ln -s . test" again.

This will cause the symlink /tmp/test to not be visible until PCManFM is refreshed with F5.

Discussion

    • assigned_to: nobody --> lstranger
    • milestone: --> 1.2
    • labels: --> 805537
    • status: open --> open-works-for-me
     
  • I cannot reproduce it. I did exactly the same steps (except I confirmed deletion, I suppose you meant it). The symlink appeared in pcmanfm window after last (7) step. I repeated it few times. Thank you very much anyway.

     
  • Sworddragon
    Sworddragon
    2013-08-14

    > except I confirmed deletion, I suppose you meant it

    Yes, I have just forget it.

    But this bug looks annoying since I'm able to reproduce it on every try.

     
  • I even tested it in virtual box with fresh ubuntu 13.10. Works just fine. I don't know how to help you, I'm sorry.

     
  • Sworddragon
    Sworddragon
    2013-08-17

    I have made a video that shows this problem (http://www.file-upload.net/download-7975930/2013_08_17_22_51_24.mkv.html). Maybe you does notice something that I have overseen.

     
    • status: open-works-for-me --> open
     
  • Yes, there is something that was missed - sidebar. With Places view all works as it should be. With Directories tree it does not. Thank you.

     
  • I cannot make a workaround unfortunately, it will make more bugs than it fixes. Reported the issue to GNOME - https://bugzilla.gnome.org/show_bug.cgi?id=706222
    Thank you very much.

     
    • status: open --> open-postponed
     
    • labels: 805537 --> isn't related to libfm or pcmanfm
    • status: open-postponed --> closed-wont-fix
     
  • GNOME still not responded to the bugreport. Unfortunately.

     
  • Sworddragon
    Sworddragon
    2014-01-04

    This isn't uncommon in most software projects. But it is fine as it is not a bug from PCManFM. I will just watch the new report and wait until something happens there.

     
  • Sworddragon
    Sworddragon
    2014-01-04

    • status: closed-wont-fix --> open-wont-fix
     
  • Sworddragon
    Sworddragon
    2014-01-04

    • status: open-wont-fix --> closed-wont-fix