Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#720 Paste disabled after selecting cut (Ctrl + x)

1.1
closed-invalid
nobody
6
2013-04-17
2013-04-01
Anonymous
No

With PCManFM: to move a file or folder, I must use "Edit -> Move to..."
"Edit -> Cut" then "Edit ->Paste" or Ctrl + x then Ctrl + v doesn't work. Paste item is disabled (insensitive)

I tried with SpaceFM: no problem, cut & paste function works properly.

Can you fix this annoying bug?
Thank you in advance!

Discussion


  • Anonymous
    2013-04-01

    • milestone: --> 1.1
     

  • Anonymous
    2013-04-01

    I have this bug since 1.0 version.

     
    • priority: 5 --> 6
    • labels: 2616493 --> 805537
     
  • Thank you very much for the bug report. Could you tell me which version do you use and does it always reproducible for you? I just never happen to meet such bug and all my friends who use pcmanfm never told me about such problem. That problem may happen if something else interferes with clipboard and changes its content so PCManFM thinks it does not contain files anymore. Check your running programs please, and try to terminate all of them that manage clipboard content - it might be clipboard manager or another file manager for example.

     

  • Anonymous
    2013-04-02

    "it might be clipboard manager"
    -> I forgot this ! I just tried without it and cut & paste works again.

    It seems it's a bug with Glippy.

     
  • I think the Glippy converts file info into plain text but plain text should never be treaten as file info because if you treat random text on clipboard as file info that may lead to unpredictable bugs. It's why other mature file managers (such as Dolphin for example) treat plain text on clipboard as data, not as file info, so does PCManFM since stable release. Report the bug to Glippy developers, please. Also you can use other clipboard manager instead (I've used Klipper and ClipIt, both are very good). Thank you very much.

     
    • labels: 805537 --> isn't related to libfm or pcmanfm
    • status: open --> closed-invalid
     

  • Anonymous
    2013-04-06

    "Report the bug to Glippy developers, please."
    -> Already done (https://bugs.launchpad.net/glippy/+bug/1163244), still no answer.

    Also you can use other clipboard manager instead (I've used Klipper and ClipIt, both are very good). Thank you very much.
    -> Now I use Diodon (https://launchpad.net/diodon)

     

  • Anonymous
    2013-04-06

    • status: closed-invalid --> open-invalid
     
    Last edit: Anonymous 2015-04-19
    • status: open-invalid --> closed-invalid