#692 Configuration is not saved

1.1
closed-invalid
pcmanfm (119)
6
2013-08-14
2012-12-28
Sworddragon
No

I'm using PCManFM 1.1.0 and it seems on some cases the configuration is not saved. For example if this configuration is created:

[config]
su_cmd=gksu %s
[volume]
mount_on_startup=0
mount_removable=0
autorun=0
[ui]
always_show_tabs=1
win_width=1680
win_height=1003
side_pane_mode=2
show_hidden=1
sort_by=2

Starting now PCManFM with this configuration and trying to change anything in the GUI (for example the view_mode) will not save the new configuration if PCManFM is closed.

Discussion

    • labels: --> pcmanfm
    • milestone: --> 1.1
    • priority: 5 --> 6
     
  • I could not reproduce this behavior so I don't how that could happen in your case. I'm sorry.

     
    • assigned_to: nobody --> lstranger
    • status: open --> open-works-for-me
     
  • Sworddragon
    Sworddragon
    2013-04-19

    Here are some detailed reproducing steps:

    1. Login into your desktop.
    2. Kill the pcmanfm process.
    3. Delete (or backup) your old configuration (in my case "rm -r ~/.config/pcmanfm").
    4. Create the default configuration directory (in my case "mkdir -p ~/.config/pcmanfm/default").
    5. Create the default configuration file ~/.config/pcmanfm/default/pcmanfm.conf and fill it with the content from the startpost.
    6. Start PCManFM from your terminal (simply "pcmanfm" without any options).
    7. If you are testing with PCManFM 1.1.0 the symbols should be very big now (view_mode 2 if I remember correctly).
    8. Try to change anything with the GUI (for example set the view_mode to small symbols).
    9. Close PCManFM.
    10. Start PCManFM again from your terminal (simply "pcmanfm" without any options).
    11. The previous GUI changes weren't saved (for example the symbols are very big again).

     
  • It was exactly what I've done. And after step 8/9 the file ~/.config/pcmanfm/default/pcmanfm.conf was updated with new values. I've tested libfm/pcmanfm from my repo (it's marked 1.0.2 there but it's the same as 1.1.0 final release). May be either your build of pcmanfm or something in your system causes that weirdness.

     
    • status: open-works-for-me --> closed-works-for-me
     
  • Sworddragon
    Sworddragon
    2013-08-14

    Just a little info because I noticed due to the conversation of this ticket (https://sourceforge.net/tracker/index.php?func=detail&aid=3614837&group_id=156956&atid=801864) an interesting behavior (PCManFM 1.1.2 and libfm 1.1.2): For example changing the automount options in the options menu will write the changes instantly to ~/.config/pcmanfm/LXDE/pcmanfm.conf. But changing how the directories are showed with the menu bar doesn't write the changes to ~/.config/pcmanfm/LXDE/pcmanfm.conf as view_mode=_number_. Maybe there is a bug in PCManFM that prevents only this setting to be saved.

     
  • Sworddragon
    Sworddragon
    2013-08-14

    • status: closed-works-for-me --> open-works-for-me
     
  • No, this is not a bug but feature. Setting view mode in menu is applied only to current view (window or tab) and never saved to configuration, it is done deliberately to let you change view temporarely to only single tab. To apply view mode to all new views there is a setting in Preferences dialog.

     
  • It seems I musunderstood you and you were talking about menu change from the very start. I'm sorry for another misunderstanding.

     
  • Sworddragon
    Sworddragon
    2013-08-14

    No, it was my fault. I haven't knewed that changing the mode with the menu bar or by presing Ctrl + 1-4 is just temporary. But I was also talking about other gui options that aren't saved too but to bad I can't remember anymore. But on testing my own 11 reproducing steps posted some time ago I'm now not able to reproduce this anymore. At least all seems to work fine now so I'm marking this ticket and the one on Launchpad as invalid.

     
  • Sworddragon
    Sworddragon
    2013-08-14

    • status: open-works-for-me --> closed-invalid