#578 pcmanfm since 0.9.8 & libfm 0.1.14 dont refresh file operati


ok now showit but i note that after 0.9.7, file monitoring now relies in
libfm and not in fam/gamin, so in pcmanfm 0.9.7 when i delete, rename or
move files, the windows refresh and updates instantaneus, but now since
0.9.8 and + this dont work,

i use/test that with gtk+ 2.18/2.20 and glib2 2.22/2.24/ and now with
gligb2 2.26,

But now in this new version is worse, because the automatic update file
operations (update/delete a file in a directory, then this "item" (file)
must disaper from the view of that directory) are not reflected, and apart
from , now pcmafn file manager crash, the crash are more frecuently when
pcmanfm manage the desktop or move icons.

should i debug and paste ooutput for that? this problem are since 0.9.8 and
libfm 0.1.14 , of course try to use lower versions of gtk+ and glib due
there's no sense in newer libraryes, due this newers software requires more
machine, and if a user have more mchine/hardware install a desktop more

i like very much the lxde and related projects due runs in my olders K6-III
and PIII machines, and mani users from latin america uses now lxde even


1 2 > >> (Page 1 of 2)
    • labels: 2616493 --> 805537
    • priority: 5 --> 4
    • milestone: 2334066 --> 2334032
  • I really don't have any problem with all the old stuff on my test debian box - it's gamin 0.1.10, glib 2.22, gtk+ 2.18, cairo 1.8.8, and no gvfs installed at all. Files show and disappear in a second I create/move/delete them, both by pcmanfm or externally. No udisks support enabled of course.
    It must be problem of your gamin configuration I think. Sorry.

    • status: open --> open-works-for-me
  • lstranger , u lie..

    pcmanfm since 0.9.8 need glib 2.24 so u responce are about 0.9.7..

    i said that since 0.9.8 and specialy 1.0.X future brand dont work very well with file operation

    i test that with deian an redhat 6, also DSL and venenux

    and new i find that when lauch pcmanf from command line said somethig like failed to monitor and put a lot of 0x0 numbers.. by now i cant debug due hav some task runnig maybe monday i finish my work and put a debug lines here.. but this its serios for old machines

  • You may offend me as much as you want. But don't think I will do anything after that.
    I cannot tell you about 0.9.8 since I have no intention to resurrect deads.
    And libfm-1.0.1 from branch can be compiled with glib 2.22 without any warnings, I've fixed all incompatible places in it especially for you.
    I've installed debian-unstable from snapshot from 23.09.2009, that debian has exactly those versions I mentioned. I've compiled libfm from mentioned git branch, installed it, then compiled pcmanfm, installed it and tested. I wrote my results with it. When I've got some crash I wrote you that it's not ready, after that I had no problems except non-working applications:// in side pane (pcmanfm hangs) but I believe that is because there is two menu-cache libraries in the same time and new one cannot work in parallel. Everything else works just fine.
    And I've tried not only that debian but I've installed Ubuntu Lucid (10.04LTS) as well and tested pcmanfm there too, no problems found.

  • there's no sense if u fixed libfm for older machines if i cannot install in debian oldstable, and lowers distributions

    i dont use debian testing, why i asked for fix libfm if testing have glib 2.30 !!!

    in winbuntu, and debian testing libfm and pcmanf works well, ok u right.. but in debian squeeze (current stable) lenny and other olders distribution (obviously more light in requeriments for older machines) file mnitoring dontk work!

    please help with that!

  • I've said nothing about CURRENT testing, I've said about unstable from 3 YEARS AGO (when lenny 5.02 came out). And lenny itself has been removed from every mirror in the world and officially ceased to exist half of year ago so I cannot test it and also AFAIR lenny has glib 2.16.6 and gtk 2.12.11 so libfm will never work on it. Sorry but there is no plans to support officially deprecated distributions. Libfm/pcmanfm should work very well on debian squeeze, it is a year newer than those I've tested already (i.e. debian snapshot from September 2009, and ubuntu lucid). Try to update gamin from squeeze and probably that will help you. If you want to use OS from year 2000 then use software from year 2000 too and nobody will help you to get software from year 2012 work on OS from year 2000, sorry, but it is too much. I can handle 3 years difference and I did it and I will keep it compatible with OS from year 2009 but don't expect anything more. Good luck!

    • status: open-works-for-me --> closed-works-for-me
  • i have instaled and testing enough with many ports..

    backported cairo 1.8.9 , pango and glib 2.25 to lenny
    backported gtk+2.0 2.21.3 to lenny
    updated fam to 2.7.0 and also gamin 0.1.10 to lenny (i prefer fam due lower resource in normal usage.. )
    update a bump of other libs (puf puf) and the finaly

    backported and compile and install libfm 1.0.1 from master.. compiles ok with --noaction flags and libfm-demo works in fime operations and updates good..

    then i compiled, and instaled pcmanfm 1.0.1 from git master and file operations still statis, i need to pulse F5 to refresh..

    using pcmanfm 0.9.7 this dont happenig!

    • status: closed-works-for-me --> open-works-for-me
    • priority: 4 --> 6
    • milestone: 2334032 --> 3086046
    • labels: 805537 --> 2616493
    • status: open-works-for-me --> open-duplicate
  • Duplicate of: https://sourceforge.net/tracker/?func=detail&aid=3561354&group_id=156956&atid=801864

    i see that in debian recent glib 2.20 and go, gio module for FAM(as same for gammin) are not enabled by default.. the package was named libgio-fam and in glib 2.24 theres no more provided ...

    so then note that libfm package in debian dont include the gio modules..

    so, then, i will re-build all (glib, cairo, pango, gtk+2 and fam/gammin) with the gio-fam module enabled in glib and libfm and test again..

    i also test previosly the pcmanfm with FAM or gammin (also included daemons) but no results..

    • labels: 2616493 --> 3376468
    • status: open-duplicate --> open-works-for-me
  • If you find a solution for that issue I would appreciate when you inform us so I (or someone else) can describe it on the wiki page. Thank you very much.

  • i'll try to compile debugging builds with a lot of prints of libfm, glib and pcmanfm with and without gio modules includes, for squeeze, and geento and post in few days results .. if i found someting..

    • milestone: 3086046 --> 1.2
    • labels: 3376468 -->
    • status: open-works-for-me --> open-remind
  • i finish test..

    1) compiled gtk 2.18, glib 2.25.15+gio modules and then libfm+gio modules + pcmanfm , works

    2) compiles gtk 2.18, glib 2.25.15 none of gio modules and then libfm+gio modules + pcmanfm , dont refresh files

    3) compiled gtk 2.18, glib 2.25.15+gio modules and then libfm none of gio modules + pcmanfm , dont refresh files

    4) compiled gtk 2.18, glib 2.25.15, libfm none of thems without gio modules + pcmanfm , work ramdomly... reinstall FAM and works.. but install fam from another hot build and dont works..

    debug info are poor, i put enough pinrts in code.. noly prints.. and if no gio module found, sais "cannot connect" etc etc ..

  • Thank you very much for testing!

  • now i discovered.. readin g glib 2.27 documentation and search on source API:

    since glib 2.27 gio modules api now has many deprecated uses and if any gtk app use glib <= 2.27, the gio modules must be included.. but if any gtk apps are compiled susing glib 2.27 or newer gio modules must be removed from both.

    ow with commit 8b18344e040244537c82f30ffab7512c1b423d42 recents versions of pcmanfm can be compiled with older glib >= 2.24 and <= 2.25.17 and gtk >= 2.18 and <= 2.22 but glib gio modules must be included in all related compilations wwhen use olders versions.. (both, libfm and glib related)

    !!!gio modules are needed on olders systems using glib < 2.26 and gtk < 2.21!!!!!

    i dont know nthig about trash behavior .. fails in a dirty env.. (geento , debian) but in debian clean frees install works...

  • Thank you very much.
    I've added the information onto Wiki page for PCManFM setup.

    • labels: --> isn't related to libfm or pcmanfm
    • status: open-remind --> closed-remind
  • please @lstranger remenber that debian has glib 2.24 without gio modules compiled and pcmanfm 0.9.7 working.. i dont know how but works..

    so this bug can be closed as so easy! u must reopen until revise more exte3nded the code around that!

    • status: closed-remind --> open-remind
  • I think your 0.9.7 was compiled against some old glib (2.16 may be) which was still exist on that computer after you've installed 2.24 (they can coexist independently, you know) and it's why it worked. If you can make fresh OS install with glib 2.24 without modules, compile that old libfm and pcmanfm, and test it, I think it will not work as well.

1 2 > >> (Page 1 of 2)