#415 0.9.8 Does not load or save --profile=

closed-wont-fix
nobody
None
4
2012-06-11
2011-02-03
Pierre
No

Refiling this bug after deleting earlier with more details.
Using Lubuntu Maverick & Pcmanfm 0.9.8 from LXDE experimental PPA. I am trying to open a second instance of PCManFM with a different config using a script or launcher. The command pcmanfm --profile=PROFILE or pcmanfm --profile PROFILE (are both ok?) do not load a new profile. It loads the lubuntu profile and saves to it also.

If it at least loaded the profile without saving, it would partially solve the problem as I could easily edit the new profile manually. But it does not.

Am I missing something? Is there a fix or work around (I need 2 instances running at the same time with different profile configurations. Let me know if you need more details.

PS. Great work with the movable icons on desktop. Thanks for all the work.

Discussion

1 2 > >> (Page 1 of 2)
  • PCMan
    PCMan
    2011-02-05

    Maybe try to use top or ps to see its full command line.
    This is what I saw here.
    pcman 1591 0.0 1.8 445052 19212 ? Sl 15:29 0:03 pcmanfm --desktop --profile lubuntu

    If pcmanfm is already launched by lubuntu as a daemon, passing a different profile to it just won't work.

     
  • PCMan
    PCMan
    2011-02-05

    • priority: 5 --> 4
    • status: open --> pending
     
  • Sworddragon
    Sworddragon
    2011-02-19

    I have such a problem too. Installing lxde-core from Ubuntu autostarts "pcmanfm --desktop --profile=LXDE". But I can't start pcmanfm as filebrowser anymore. A workaround is to disable the automatic starting of "pcmanfm --desktop --profile=LXDE" so that the default profile is used. But with the default profile I can't use the desktop anymore. There are no desktop files and a background image and this can't be changed.

     
  • This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending --> closed
     
  • Pierre
    Pierre
    2011-02-19

    Not sure why this is closed.

    Pcmanx: I also tried in a script to replace 1st Lubuntu config file with my second config, tried loading a second instance of pcmanfm with this new profile, and then replace the 2nd config with 1st config. It still did not accept to load with this different profile. Loaded profile seem to be loaded into a temp file which used to open all new instances. Where might that temp file be located. I could not find it. It could be a workaround for me. Tx.

    Sworddraggon: I did try removing --desktop --profile=Lubuntu (in my case). However, it loaded again the Lubuntu profile which is the default and did not allow me to start a 2nd instance with second profile.

    Did you know that 'pcmanfm --desktop' will load your desktop icons? Try with the run command (Alt-F2). If it works, create a launcher for it and place in ~/.config/autostart (create folder as necessary). That should solve your problem although it will not solve mine.

     
  • Pierre
    Pierre
    2011-02-19

    • status: closed --> open
     
  • Sworddragon
    Sworddragon
    2011-02-22

    My problem is now fixed with PCManFM 0.9.9. Maybe your problem will get solved too with this version.

     
  • PCMan
    PCMan
    2011-02-23

    Actually, this is not a bug, but the desired behavior.
    1. Currently PCManFM doesn't support running 2 different instances.
    2. Because of 1, only one profile is allowed.
    3. The --profile argument only affects the first instance.

    Allowing different instances can create several problems:
    1. When a new window is going to be opened, which instance should be called?
    2. Dramatic increase of memory and resource usage.
    3. Decrease performance since the cached data cannot be shared by different instances.
    4. volume management might have problems in some cases due to clashes between two instances.
    5. The program can become much more complicated.

    So, I'm not going to support it at this moment. I, however, should address this issue clearly in --help or manpage.
    If you got good patches for this, I'll review them as soon as possible. Otherwise I will fix documentation only.
    Thanks.

     
  • PCMan
    PCMan
    2011-02-23

    • status: open --> open-wont-fix
     
1 2 > >> (Page 1 of 2)