dissapearing traces

Help
2008-09-23
2013-05-29
  • dee factorial
    dee factorial
    2008-09-23

    I find that after 6 months of creating a pcb there seems to be a state that the PCB application gets into where it will turn the traces that I have created into traces that don't intersect the polygon. They just disappear into the polygon. They are still there if I select them. but they no longer have a clearance around them. This is only some of the traces not all of them.

    if I generate an object report for the trace it still has the "clearline" flag attached to it yet it doesn't have any space around it within the polygon.

    Could this have anything to do with when the ground plane/polygon goes through a really small space.

    I have even tried to remove the polygon and draw another overtop and the problem still persists.
    The last time this happened I had to revert to an old version of my file and redo the traces.

    ps: I'm using version 20080202 for ubuntu 7.10.

     
    • DJ Delorie
      DJ Delorie
      2008-09-23

      Check to see if you have two overlapping lines instead of just the one.

       
    • dee factorial
      dee factorial
      2008-09-24

      yes some of the times there are many overlapping lines. I have to change the line from 10mil to 8mil. so often I will add do an existing line. Both lines have the Clearline flag set. How would two intersecting lines create that glitch? 

       
      • DJ Delorie
        DJ Delorie
        2008-09-24

        If you remove one of the two overlapping (not just intersecting) lines and it starts working, that's a known bug in the polygon code.

         
        • dee factorial
          dee factorial
          2008-09-24

          Is there any documentation on this error. I would like to look it up, who knows maybe I would even submit a patch. I just tried to delete some of the lines and the application crashed. it looks like it was working though. I'll reload the application and try again.

          error message:

          Error while clipping PBO_SUB: 3
          Error while clipping PBO_SUB: 3
          Segmentation fault (core dumped)

          where does it dump the core ? and how do I read it ?

           
          • DJ Delorie
            DJ Delorie
            2008-09-24

            You should get and try the CVS version of pcb first, in case it's already fixed.

             
            • dee factorial
              dee factorial
              2008-09-24

              I installed the cvs version and the problem still persists.
              version 1.99x
              Compiled on Sep 24 2008 at 10:29:38

              I've found the Bug you referenced.
              1951502

              I'll try deleting the affected intersections without getting a seg fault. Then I'll try looking into the code that is referenced in the bug report.