Newbie installation issues

Help
2009-06-28
2013-05-29
  • Hi!

    I installed openSUSE 11.1 just yesterday, so i am very fresh at all this.

    This is the first program that i have tried to install using ./configure, make, make install.

    The problem occurs when i run ./configure. It starts checking a lot of things, but halts with an error:

    checking for wish... no
    checking for wish83... no
    checking for wish8.3... no
    checking for wish80... no
    checking for wish8.0... no
    checking for cygwish83... no
    checking for cygwish80... no
    configure: error: Did not find the wish executible.  You need to make sure
            that tcl is installed on your system and that wish is in your path

    I searched for tcl in Yast softwar manager, and installed the tcl programming language, and all components except development. But it did not solve the problem.
    cant find any information about the wish executable.

    Can somebody help me with this?

    Thanx

    //John

     
    • Robert Heller
      Robert Heller
      2009-06-28

      You need the tk package:

      sauron.deepsoft.com% rpm -qf /usr/bin/wish
      tk-8.4.7-3.el4_6.1

      The tk package is the base GUI ToolKit for Tcl.

       
    • Further problems:

      That worked well... the ./configure found wish and continued to check alot of things.

      Now it got stuck at:

      checking for gdlib-config... no
      Cannot find gdlib-config.
      Make sure it is installed and in your PATH.
      gdlib-config is part of the GD library available from www.boutell.com/gd.
      This is needed for the png HID.  I will look for libgd anyway and maybe
      you will get lucky.

      checking for main in -lgd... no
      configure: error: You have requested the nelma and/or png HID  but -lgd could not be found

      I downloaded gd 2.0.35 and installed it. but i still get the same error from ./configure

      any ideas?

       
      • Robert Heller
        Robert Heller
        2009-06-28

        There should br RPMs for gd and gd-devel:

        sauron.deepsoft.com% rpm -q gd gd-devel
        gd-2.0.28-5.4E.el4_6.1
        gd-devel-2.0.28-5.4E.el4_6.1

        You will need both.

         
    • That did it. Thank you very much

      //John