Problems with PB Jelly 13.10.22

2014-01-20
2014-02-19
  • Dear Adam, first of all thanks for the tool, however I have problems with running it.
    From the very first stage (setup) I have the following error:

    ######33

    Usage:
    USAGE: Setup.py <inputScaffolding.fasta> <inputScaffolding.qual> [outputContigs.fasta]

    Take the input scaffolding and split it into contigs around all [Nn]+

    Setup.py: error: Error! Incorrect number of arguments

    ####333

    The protocol file reads

    #

    <jellyProtocol>
    <reference>/srv/GT/analysis/p1169/ALL_PATHS/3_PE_AND_ALL_MP_PE_COV_50_AND_MP_COV_100/ATT1/ASSEMBLIES/test/final.assembly.fasta</reference>
    <outputDir>/srv/GT/analysis/p1169/ALL_PATHS/PB_JELLY_13_OUT</outputDir>
    <blasr>-minMatch 8 -sdpTupleSize 8 -minPctIdentity 75 -bestn 1 -nCandidates 10 -maxScore -500 -nproc 2 -noSplitSubreads</blasr>

    <job>Full_PacBio_dataset_subreads.fastq</job>

    </jellyProtocol>

    and all the files and dirs are in place.

    The networkx 1.1 is also installed correctly (in fact when I use PBJelly v 12 it works, but then I have another problem, see other post).

    Any ideas why?

    Thanks,
    G

    3 I run the standard

    Jelly.py setup protocol_file

     
  • sorry, the protocol file is attached, Iguess it's easier.

     
    Attachments
  • Adam English
    Adam English
    2014-01-21

    My only guess based on the information you've given me is that you're environment paths may be messy since. Can you ensure that PBJv12 is not in your environment at all. Try running

     which Setup.py
    

    and check if the path given is PBJv13.* you're using. If that isn't the case, I'd need more information - like have you been able to run through the toy example and maybe could you try running Setup.py directly?

     
  • Hi Adam, that problem is sorted, thanks, now I am using version 14.1.14 and I am encountering a different issue.

    The setup step is completed, but then the filtered_subreads.fastq.err reads

    2014-01-26 15:39:35,680 [INFO] Running /usr/local/ngseq/src/Jelly_14.1.14/bin//m4pie.py /usr/local/ngseq/src/Jelly_14.1.14/docs/jellyExample/mapping/filtered_subreads.fastq.m4 /usr/
    local/ngseq/src/Jelly_14.1.14/docs/jellyExample/data/reads/filtered_subreads.fastq /usr/local/ngseq/src/Jelly_14.1.14/docs/jellyExample/data/reference/lambda.fasta --nproc 4 -i
    Traceback (most recent call last):
    File "/usr/local/ngseq/src/Jelly_14.1.14/bin//m4pie.py", line 203, in <module>
    run(sys.argv[1:])
    File "/usr/local/ngseq/src/Jelly_14.1.14/bin//m4pie.py", line 165, in run
    aligns = M4File(args.m4)
    File "/usr/local/ngseq/src/Jelly_14.1.14/pbsuite/utils/FileHandlers.py", line 473, in init
    file = open(file,'r')
    IOError: [Errno 2] No such file or directory: '/usr/local/ngseq/src/Jelly_14.1.14/docs/jellyExample/mapping/filtered_subreads.fastq.m4'

    As you can see from the files, it fails also on the example data (same error as I see on my real data).
    Any help appreciated. Btw, what is m4pie.py for?

    Thanks,
    G

     
  • Jiaze Wu
    Jiaze Wu
    2014-02-10

    I had this error also. I figured out that the fasta reference needs a suffix array that could be created by sawriter in smrtanalysis.

     
    Last edit: Jiaze Wu 2014-02-10
    • Hi Jiaze, thanks for your answer, unfortunately that is not the case for me.
      The .sa files are created with no problems at setup stage: the problem is at mapping stage, where this .m4 file (which as far as I am aware is not mentioned anywhere in the documentation) is missing.
      Hope Adam will reply soon, as it seems pretty strange that things do not work even with the dummy data.

      Best,
      G

       
  • Adam English
    Adam English
    2014-02-19

    Does the file:
    /usr/local/ngseq/src/Jelly_14.1.14/docs/jellyExample/mapping/filtered_subreads.fastq.m4
    exist?

    If not, you're not running blasr correctly. You should A) ensure it's in your environment and B) ensure that the parameters you're passing to it from your protocol.xml are all formatted correctly.