The build 0.92BETA requires libykpers version >= 1.7 which is not available for 12.04.
I tried installing passwordsafe-ubuntu-0.92BETA.i686.deb ignoring this dependency (dpkg --ignore...) and it does install, but when I run it, it shows the error:
pwsafe: /usr/lib/i386-linux-gnu/libykpers-1.so.1: version `LIBYKPERS_1.7' not found (required by pwsafe)
Could you please rebuild this package without Yubikey support?
There is a similar open thread, but it seems to be about the 64-bit package, while this is about the i686 version.