#406 Please rebuild passwordsafe-ubuntu-0.92BETA.i686.deb without Yubikey dependency

v1.0_(example)
open
nobody
None
1
2014-06-24
2014-03-14
AleR
No

The build 0.92BETA requires libykpers version >= 1.7 which is not available for 12.04.

I tried installing passwordsafe-ubuntu-0.92BETA.i686.deb ignoring this dependency (dpkg --ignore...) and it does install, but when I run it, it shows the error:

pwsafe: /usr/lib/i386-linux-gnu/libykpers-1.so.1: version `LIBYKPERS_1.7' not found (required by pwsafe)

Could you please rebuild this package without Yubikey support?

There is a similar open thread, but it seems to be about the 64-bit package, while this is about the i686 version.

Thanks!

Discussion

  • This problem also exists in Ubuntu 14.04, where the libykpers version is >=1.7. Transcript follows

    jonathan@Odin:~/Downloads$ sudo dpkg --install passwordsafe-ubuntu-0.92BETA.i686.deb 
    Selecting previously unselected package passwordsafe.
    (Reading database ... 322875 files and directories currently installed.)
    Preparing to unpack passwordsafe-ubuntu-0.92BETA.i686.deb ...
    Unpacking passwordsafe (0.92BETA) ...
    dpkg: dependency problems prevent configuration of passwordsafe:
     passwordsafe depends on libykpers-1-1 (>= 1.7.0-1).
    
    dpkg: error processing package passwordsafe (--install):
     dependency problems - leaving unconfigured
    Processing triggers for man-db (2.6.7.1-1) ...
    Errors were encountered while processing:
     passwordsafe
    

    However, libykpers is installed, at version 1.14.1:

    jonathan@Odin:~/Downloads$ dpkg -l | grep libykpers
    ii  libykpers-1-1:amd64                       1.14.1-1                                            amd64        Library for personalization of YubiKey OTP tokens
    

    Installing with --ignore-depends succeeds...

    jonathan@Odin:~/Downloads$ sudo dpkg -i --ignore-depends=libykpers-1-1 passwordsafe-ubuntu-0.92BETA.i686.deb
    (Reading database ... 322908 files and directories currently installed.)
    Preparing to unpack passwordsafe-ubuntu-0.92BETA.i686.deb ...
    Unpacking passwordsafe (0.92BETA) over (0.92BETA) ...
    dpkg: dependency problems prevent configuration of passwordsafe:
     passwordsafe depends on libykpers-1-1 (>= 1.7.0-1).
    
    dpkg: error processing package passwordsafe (--install):
     dependency problems - leaving unconfigured
    Processing triggers for man-db (2.6.7.1-1) ...
    Errors were encountered while processing:
     passwordsafe
    jonathan@Odin:~/Downloads$ dpkg -l | grep passwordsafe
    iU  passwordsafe                              0.92BETA                                            i386         Portable version of popular password manager program
    

    ...but it doesn't run...

    jonathan@Odin:~/Downloads$ pwsafe &
    [1] 7303
    jonathan@Odin:~/Downloads$ pwsafe: error while loading shared libraries: libykpers-1.so.1: cannot open shared object file: No such file or directory
    
    [1]+  Exit 127                pwsafe
    

    ... despite the fact that libykpers-1.so.1 appears to be properly linked:

    jonathan@Odin:~/Downloads$ ls -lart /usr/lib/x86_64-linux-gnu/libykpers*
    lrwxrwxrwx 1 root root    21 Oct 22  2013 /usr/lib/x86_64-linux-gnu/libykpers-1.so.1 -> libykpers-1.so.1.14.1
    -rw-r--r-- 1 root root 70400 Oct 22  2013 /usr/lib/x86_64-linux-gnu/libykpers-1.so.1.14.1
    

    I have reverted to v0.8BETA (passwordsafe-ubuntu-0.8BETA.i686.deb) which I have been using with no problems for many months.

    Platform information:
    AMD Phenom II X4 965
    jonathan@Odin:~/Downloads$ uname -a
    Linux Odin 3.13.0-29-generic #53-Ubuntu SMP Wed Jun 4 21:00:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

    KDE 14.04; KDELibs 4.13.1