Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#106 Change default options to be more secure by default.

open
nobody
5
2012-09-17
2003-12-18
Anonymous
No

I have tired the pre 2.0 and it is working fine. I
suggest that the features below are needed before/in
the 2.0 final release. At work, I still use 1.92.

1) Installer
2) "Default" settings should include:
- Security:
a) Clear clipboard on minimize or exit
b) Lock password database on minimize
c) Confirm password databse save on minimize
- Password Policy:
a) lenght=8 (or even higher)

Thanks

Moueen

Discussion

  • PSafe_Options_Security

     
    Attachments
  • Jeff Lawson
    Jeff Lawson
    2004-07-18

    Logged In: YES
    user_id=511066

    1) installer now exists.

    2b) Upcoming 2.04 version features automatic locking when
    your workstation is locked (or screensaver kicks in).