not a valid Win32 application error

Help
Tranas
2011-01-10
2012-09-17
  • Tranas
    Tranas
    2011-01-10

    not a valid Win32 application error shows when installing v3 24.1 on Win2K
    machines. Assistance in resolving this issue would be appreciated,

    TIA

     
  • Rony Shapiro
    Rony Shapiro
    2011-01-10

    Hi,

    This is because we've built 3.24.1 with the latest version of Microsoft's
    development tool (Visual studio 2010), which only supports target operating
    systems of Windows XP, Vista and Windows 7 - the header in the executable
    states it requires OS version 5.1 or greater, and Windows 2000 is version 5.0.
    Windows 2000 left Mainstream Support on 30 June 2005 and Extended Support
    (that you have to pay MS for!) on 13 July 2010. Because of this, Microsoft
    removed it from the list of supported target OSes of VS2010.

    Your best bet is to use a previous version of PasswordSafe - 3.23.1 should
    still work, and there are no critical bugs in that version.

    I will modify the installer to warn about this when trying to install on win2k
    machines - sorry about the confusion.

     
  • Tranas
    Tranas
    2011-01-10

    Thanks,

    I expected that would be the case.

    3.23 works just fine on the 2K boxes and we have had no issues with it since
    it came out.

    Password Safe is a great program and your effortrs keeping it that way are
    sincerely appreciated.