How to set default database

Help
2010-02-15
2012-09-17
  • Mike Frerichs
    Mike Frerichs
    2010-02-15

    I just updated my Password Safe to version 3.21 from some version that was at
    least a year or two old. I'm running it on a WinXP SP3 machine with all the
    latest patches installed. I only have one password database and the help file
    says that the Safe Combination Entry screen will show the last database that I
    used, by default. I've been using Password Safe since before it was a
    SourceForge project and it has always worked that way. Now, however, with
    V3.21 I have to select my database from the dropdown box every time I start
    Password Safe. I can't find any options to change this behavior. I searched
    through the bug reports but couldn't find anything. Am I missing something? Is
    this a new "feature"?

     
  • Rony Shapiro
    Rony Shapiro
    2010-02-15

    Hm,

    A quick workaround would be to pass the name of the database as an argument to
    PasswordSafe, for example, by editing the shortcut properties of the
    shortcut/Start menu entry you use to start PasswordSafe.

    Will investigate this later.

    Rony

     
  • Mike Frerichs
    Mike Frerichs
    2010-02-16

    Thanks for that idea. I hadn't thought of that and it does work.

    By the way, what's the proper way to report a bug in Password Safe (or any
    SourceForge project)? Do I just create a topic in the forums as I did in this
    case, or is there something more formal that I, as a non-SourceForge-
    developer, should do? There appears to be one other very small but anoying bug
    in 3.21 that I'd like to mention in the proper place.

    Thanks,

    Bugwriter

     
  • Mike Frerichs
    Mike Frerichs
    2010-04-22

    steve nunubiznez e-mailed me to ask how to edit a shortcut so that PWS could
    open a database when it's started. I replied to you but the e-mail you put on
    your account must be wrong as my reply bounced. On the off chance that you're
    not some kind of scammer, I'll post my reply here and hope you see it.

    Steve,

    It's pretty easy. Go to the shortcut that you want to edit. If you have more
    than one shortcut that you use (I have one on my shortcut bar, one on the
    startup menu, and one on my favorites bar in Internet

    Explorer) you have to edit each one. If you edit one shortcut and then copy it
    someplace, the new copy will contain the edit.

    Right click on the shortcut.

    Select Properties at the bottom.

    Click on the Shortcut tab if you're not already on that tab.

    The Target path probably reads:

    "C:\Program Files\Password Safe\pwsafe.exe"

    (with the quotation marks)

    Add a space after what's already there, and then the path to your database,
    also in quotation marks.

    For example, mine looks like this: "C:\Program Files\Password Safe\pwsafe.exe"
    "C:\Documents and Settings\M51\My Documents\Documentation\Password Safe
    Data\Home.dat"

    Click OK at the bottom of the form and you're set to go.

    Mike

     
  • BigRed
    BigRed
    2010-04-26

    I'm seeing the same issue after upgrading to 3.21. I tried going back to 3.17,
    but the same behavior persists,

     
  • BigRed
    BigRed
    2010-04-26

    I didn't see the reply/workaround before. The workaround works. Thanks. My
    shortcut had a -s parameter before. I removed that. Not sure what it was for.

     
  • DrK
    DrK
    2010-04-26

    From the Help file on Command Line Arguments:

    pwsafe -s

    This will start the application "silently", that is, minimized and with no
    database (unless one is specified). When the application is unminimized, the
    user is presented with the opening dialog box (This option is meant for
    starting the application upon login, via a shortcut in the user's Startup
    folder). Note: This implicitly puts the application in the system tray.

    So, if there is a Bug, it is when opening PasswordSafe after starting it
    initially with the 'silent' argument with no database specified.

    David

     
  • TimScot
    TimScot
    2010-12-19

    From another thread:

    Try exiting PasswordSafe via the menu File->Exit after opening your database.
    This will cause passwordsafe to record the last database opened, and it should
    then 'remember' it next time you start your machine.

     
  • David Walker
    David Walker
    2011-01-13

    That is great to know, and it works, but it's not very "discoverable". I was
    also annoyed that the new Password Safe would not remember the last database
    used. I only have one database.

    The workaround works, but I typically close programs in Windows using the "X"
    on the title bar.

    Here's a vote that someone can fix this bug at some point. Or at least fix the
    Help file (which INCORRECTLY says that PasswordSafe will show the last
    database used). It will not open the last database used if you use the X to
    close the program.

    Thanks.

     
  • jBeard
    jBeard
    2011-02-17

    I have Win7 with version 3.24.01 and my experience as a new user is that after
    creating a new database, and when double clicking the password safe icon in
    the system tray, I am never directed to the screen allowing entry of the
    master password. I have not been able to discover a method to retain the
    default database so that it doesn't need to be selected each time.

    I also noticed that if I minimize password safe without entering the master
    password, the icon in the system tray changes to the picture that indicates
    the database is unlocked even when it has not been unlocked.

    It would be great to hear if anyone else has encountered this behavior and
    might have a fix?

     
  • Rony Shapiro
    Rony Shapiro
    2011-02-19

    Jbeard01,

    I'm a bit confused by your description. Here's how PasswordSafe works:

    1. When the system tray icon's RED, then the database is unlocked, that is, you don't have to enter the master password to access it - double-clicking's enough.
    2. When the icon is GREEN (think safe-secure), then double-clicking will bring up the prompt for the master combination. Green = 'locked' database.
    3. By default, after a few minutes idle time (not using PasswordSafe), the application locks the database.

    You can configure the idle time via Manage->Options->Security->Lock password
    database after N minutes idle, and also have it lock everytime you minimize
    the app, which is perhaps what you were expecting.

    Cheers,

    Rony