Tree [r5083] / tags / V3_25 /
History



File Date Author Commit
CodeBlocks 2010-11-24 c-273 [r3801] Remove Expat from last files. NOTE: After upda...
CodeLite 2010-12-30 sauravg [r3879] Updated with new files
Misc 2011-01-02 ronys [r3886] 2010->2011 - happy new year
Xcode 2011-02-06 sauravg [r3947] Added x86_64 target, for wxOSX_COCOA build
docs 2011-03-16 c-273 [r4042] Typos
help 2011-03-07 pm_kan [r4026] updates in Russian help
install 2011-03-16 ronys [r4039] Updates to Korean texts, thanks to Seunggyun Hong
src 2011-03-16 c-273 [r4040] Silly typo
xml 2011-02-26 c-273 [r3997] Formatting nits
LICENSE 2010-09-16 ronys [r3685] Fixed formatting problem - LICENSE now displays...
Makefile 2010-07-15 ronys [r3545] tweak last commit
Makefile.linux 2011-02-26 ronys [r3996] Get the ball rolling for 3.25
Makefile.macos 2010-11-24 c-273 [r3800] Rename 'corelib' to 'core'
Makefile.windows 2011-03-14 ronys [r4036] Load 3.25 in the barrel
README.LINUX 2010-09-30 ronys [r3699] Elaborated Linux Ubuntu install instructions, b...
README.LINUX.DEVELOPERS.txt 2011-02-08 ronys [r3950] Tweak debian dependencies - checked against Deb...
README.MAC.DEVELOPERS.txt 2010-12-11 sauravg [r3855] Some documentation for building on OS X
README.WINDOWS.DEVELOPERS.html 2010-12-15 c-273 [r3863] Update project files - compiler warning level 4...
README.txt 2009-05-28 ronys [r2673] Updated README.txt (long overdue)
pwsafe.sln 2010-12-15 c-273 [r3863] Update project files - compiler warning level 4...
pwsafe8.sln 2010-11-24 c-273 [r3800] Rename 'corelib' to 'core'
pwsafe_wx.sln 2010-12-01 c-273 [r3818] Tidy up VS2010 projects as much as it would all...
pwsafe_wx8.sln 2010-11-24 c-273 [r3800] Rename 'corelib' to 'core'

Read Me

1. Introduction:
The Linux port of PasswordSafe is currently in BETA.
This means that (1) you should take care to keep copies of the
database to protect against possible loss of data due to bugs, and (2)
there are several unimplemented features. Nonetheless, we feel that
this is good enough to release as an early beta to gather feedback
from a wider audience.

2. Supported Distributions:
Currently Debian 5.0 and Ubuntu 10.04.1 are supported.

3. Installation:
3.1 Download the .deb file that corresponds to your distribution.
3.2 Install it using dpkg (for experienced user):
$ sudo dpkg -i passwordsafe-*.deb
Dpkg will complain if prerequisite packages are missing. To install
the missing packages:
$ sudo aptitude install missing-pkgX missing-pkgY
3.3 Installing using GUI:
3.3.1 Ubuntu:
If you download passwordsafe-ubuntu-0.1-1.deb to Ubuntu 10.04, and
open it with GDebi Package Installer, the Package Installer may give
an Error: Dependency is not satisfiable: libwxgtk2.8-0 (>=
2.8.10.1-0ubuntu1.2). If so, click on Applications, Ubuntu Software
Center, search for wxw, select wxFormBuilder and Use This Source. Then
click on Install - Free. Afterwards, you should see a green check box
next to Installed. Then close your Package Installer window, and
double-click again on passwordsafe-ubuntu-0.1-1.deb in your Firefox
Downloads menu. This time the package installer comes up again and you
can Install Package. While you cannot simply double-click on an
existing .psafe3 file, you can go to usr/bin/ and double-click on
pwsafe. There, it will look for your .psafe3 or .dat files by
default. Also, in your Nautilus File Browser, you can right click on
pwsafe and Copy to Desktop.
3.3.2 Debian: TBD

4. Reporting bugs:
Please submit bugs via
https://sourceforge.net/tracker/?func=add&group_id=41019&atid=429579
Set the Category field to Linux to help ensure timely response.