Hi Andrey -

Very glad that's helped locate it - it's been a tough one. And I can confirm that unchecking Lock Database on Minimise is a work-around, though not a very desirable one! I look forward to testing an updated version.

Best regards - Philip

On 04/04/2014 14:26, Andrey Kuznetsov wrote:

Hi Philip,
Thanks for dump and stack trace!
Now I can reproduce the issue: this message is shown when "Lock database on minimize" enabled (DatabaseClear set to 1 in config file). [As temporary workaround, you may disable this option until issue will be fixed.]
I'll debug and fix it tomorrow.


[bugs:#1149] "Requested mode change failed"

Status: accepted
Group: v1.0_(example)
Created: Sun Dec 08, 2013 08:07 PM UTC by Philip Le Riche
Last Updated: Tue Apr 01, 2014 05:01 AM UTC
Owner: Rony Shapiro

Having upgraded to v3.32, launching PaswordSafe (with -s option) gives a popup with a title "Requested mode change failed", saying "Failed to switch from R/W to R-O: Could not release database lock." Clicking OK, PasswordSafe appears to run normally.


Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/passwordsafe/bugs/1149/

To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/