Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#993 debian-0.7.0BETA depends on wrong version of libxerces

open
nobody
None
5
2012-09-17
2011-10-30
Graeme
No

Debian squeeze 6.0.3.

Installed debian-0.7.0BETA and it failed to launch:

graeme@vulagi:~$ pwsafe
pwsafe: error while loading shared libraries: libxerces-c-3.1.so: cannot open shared object file: No such file or directory

Looking inside the package, DEBIAN/control contains the following:

Package: passwordsafe
Version: 0.7.0BETA
Section: utils
Priority: optional
Conflicts: pwsafe
Architecture: i386
Maintainer: Rony Shapiro ronys@users.sf.net
Homepage: http://pwsafe.org/
Depends: libc6 (>= 2.7-18lenny4), libwxgtk2.8-0 (>= 2.8.7.1-1.1+lenny1), libuuid1 (>= 1.41.3-1), libxtst6 (>= 2:1.0.3-1), libxerces-c28 (>= 2.8.0-3+lenny1)
Description: Portable version of popular password manager program
pwsafe is the Linux version of the popular Windows PasswordSafe
password manager.
.
Features:
- Compatible with 1.x, 2.x and 3.x versions of the database format.
- Uses wxWidgets for portability.
- Supported by the maintainers of the original Win32 program. See
http://pwsafe.org/

libxerces-2.8 was installed, so the dependency was satisfied.

"apt-get install libxerces-c3.1" fixed the problem, but I believe that the package's dependency should be changed.

Thanks for maintaining a great package. I use it on Windows, Linux and Android.

Regards
Graeme

Discussion

  • Huw
    Huw
    2012-01-09

    Category should be Linux.