Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#983 Linux Beta will not open pwsafe.dat file

open
Saurav Ghosh
Linux (75)
5
2012-09-17
2011-08-13
Mark Englund
No

Description: Initial Open Password Database dialog opens up(see attached screenshot) and after I add the Safe Combination I get an error:

mwe@tiger:~$ pwsafe ./pwsafe.dat
mwe@tiger:~$ pwsafe: PWSfileV1V2.cpp:397: size_t PWSfileV1V2::ReadCBC(unsigned char&, StringX&): Assertion `wcLen != 0' failed.

If I try and click on the keyboard icon on the login dialog I get the following error:

mwe@tiger:~$ execvp(xvkbd) failed with error 2!

Operating System: Ubuntu 10.10
"uname -a" output:
Linux tiger 2.6.35-30-generic #56-Ubuntu SMP Mon Jul 11 20:00:22 UTC 2011 i686 GNU/Linux

Other info:
The same password safe file opens fine on Windows XP under Password Safe version V3.16.02 (2504)Y

Discussion

  • Saurav Ghosh
    Saurav Ghosh
    2011-08-13

    I'm pretty sure the assertion problem was fixed with 3357926.

    For the xvkbd problem, do you have xvkbd installed?

     
  • I downloaded the most recent package yesterday, and I get the same assertion error.

    My "uname -a":
    Linux Weston 2.6.35-22-generic #33-Ubuntu SMP Sun Sep 19 20:32:27 UTC 2010 x86_64 GNU/Linux

     
  • Saurav Ghosh
    Saurav Ghosh
    2011-09-17

    tjeffress - The problem was fixed after the last/latest package was released on 20110707. If you can check out the sources from svn and build it yourself, it would be fixed for you. Or else, it would be available in the next release.