Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#536 V3.08 doesn't remember last opened database

open
nobody
None
5
2012-09-17
2007-06-04
Gerhard
No

PWSave 3.08 doesn't remember last opened database.
Maybe this is because my username holds a non Ascii character (german ö). In the pwsave.cfg file (attached) the xml tag with my username is not stored correct (begin is diffenent to end tag).

Steps to reproduce:
1. start PW-Save
2. create new database
3. add some entry in database
4. exit PW-Save
5. start PW-Save

Expected behaviour:
path to database created in step 2 selected in filed "Open Password Database"

Actual behaviour:
file "Open Password Database" is empty; but PW-Save opens correct directory when pressing on the "..." button.

Discussion

  • Gerhard
    Gerhard
    2007-06-04

    pwsave.cfg showing mismatching tags

     
    Attachments
  • Gerhard
    Gerhard
    2007-06-04

    Logged In: YES
    user_id=1661500
    Originator: YES

    I tested also with v3.08.01 (from [1729740]) and problem exists also in this version.

    Besides the database also opions like "System==>Put icon in system tray" get lost.

     
  • Gerhard
    Gerhard
    2007-06-24

    Logged In: YES
    user_id=1661500
    Originator: YES

    I think this issue is the same then "1735290 cfg file doesn't support non-ascii usernames in 3.08".

    I tested with 3.08.03 and now the cfg file looks better and PW save remembers the last database.

     
  • Logged In: NO

    I'm seeing a similar bug in 3.09. When working with multiple databases PWS doesn't seem to follow any rule. Often opening a database other than my "normal" database will cause that the become the default database. It can then take as many as a dozen attempts to make my normal database the default again. Even deleting the second database does not solve the problem.

     
  • Berkhout
    Berkhout
    2007-09-15

    Logged In: YES
    user_id=1522323
    Originator: NO

    Still true in version 3.10 (1664)...
    PWS started with -s option.

     
  • This seems to also be a problem in the latest release (3.14).