Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#480 data area blank after restore

open
nobody
V3 (197)
5
2012-09-17
2007-02-15
Larry
No

Hi Rony, I just tried PWS 3.06 on my XPhome fully patched system. I was using version 3.04. The bug I found was that when I tried to restore, the data area came up blank. I then tried to click on the most recently used database under FILE but got the message "file already open". I had to close down PWS and reopen it before the data would appear. Same thing happened when I tried a restore this time as well. Have reverted to 3.04.
Larry

Discussion

  • Larry
    Larry
    2007-02-15

    Logged In: YES
    user_id=1445539
    Originator: YES

    and more testing has determined that if the screen is maximised, the problem described above happens. If, however, I view the screen in a minimised view (and stretch it out to full screen) the problem does not exist. Knowing this workaround, I have reinstalled 3.06.

     
  • Logged In: NO

    I'm using 3.05.02 on a Windows 2000 PC and am seeing the same problem. When I try to restore, the data area comes up blank. When I tried to click on the most recently used database under FILE, I got the message "file already open". I had to close down PWS and reopen it before the data would appear.

     
  • Larry
    Larry
    2007-03-04

    Logged In: YES
    user_id=1445539
    Originator: YES

    More info re this: I have re-installed 3.06 and am using it on my home PC as well as the U3 beta. Workaround is to restore; and if it comes up blank, minimize then maximize, and the database then shows on the screen. If I stretch out the view to a complete full screen in the minimized view, the screen comes up blank but if you stretch it out to say 95% instead of to the edge of the screen all around, then it will restore ok. I also find that if I X out of the database with a 95% stretched out minimized view, the program does not remember this the next time I use it and the small minimized view (too small to be of any use)IS SHOWN. This also happens in the U3 version. I'm not sure if this happens in previous versions because they would remember the 95% setting and the problem didn't exist because of that.

     
  • pacware
    pacware
    2007-04-08

    Logged In: YES
    user_id=1764375
    Originator: NO

    I am seeing the same problem on 3.07 on XP.

    The key to reproducing this problem is to minimize the window when it is maximized. Then when you restore it, it will restore to the maximized size, and you will not see anything.

    But if the window is not maximized, and then you minimize it, and then you restore it, you won't see the problem. And then if you maximize it, you still won't see the problem.

     
  • John B
    John B
    2007-04-20

    Logged In: YES
    user_id=1774343
    Originator: NO

    This problem was introduced for me in version 3.0.6
    I hoped it would be fixed in 3.0.7 but I still have the same problem
    I found the following behaviour :

    1. Edit a password entry and leave the View Entry Screen open
    2. Password Safe minimises to the System Tray after a few minutes
    3. Right Click on System Tray Icon and select Restore option
      Type in the safe combination
      Password Safe is maximised, with the View Entry Screen still open
      But the grid behind it is totally blank
    4. Close the View Entry Screen
      The main grid remains totally blank
      But the Menu entries are enabled
    5. Select File->Exit to exit the application
    6. Run Password Safe again