#1021 Strange behaviour when creating new entries

v1.0_(example)
closed
nobody
None
5
2013-01-09
2012-04-01
andrey-zh
No

I have a kinda large password database (about 50 groups and 200 entries). When I want to create a new group it doesn't happen. Instead a new entry may be created somewhere inside database tree with the name of the group. (That is I'm able to create a new group, but when I press Enter to confirm its name, the things described above happen.) This happens with Password Safe v3.28, but I first noticed this some time ago (around v3.18, maybe later).

Please note that some entry names contain period "." and space characters.
I'm still able to create groups by specifying their names in new entry dialog like SubGroup.NewGroup.NewEntry.

Discussion

  • DrK
    DrK
    2012-04-01

    Someone has reported a problem creating groups with 3.28 only. See Help Forum entry: http://sourceforge.net/projects/passwordsafe/forums/forum/134801/topic/5112858

    Note: Group names must not contain periods ('.') which are used to distinguish between groups and their sub-groups e.g. creating group "a.b.c" would create a group 'a' with a subgroup 'b' which in turn had a subgroup 'c'.

    David

     
  • andrey-zh
    andrey-zh
    2012-04-03

    I've looked through all of my groups. None of them contain period in their names.

    I believed that some inner structure of the database has been corrupted. So I tried to export it to various formats with as few fields as possible to import it back. I never succeeded in importing data back. Every time I tried, I got the following error message about parsing error:

    One or more Password Policy Names were not found in the database. The affected entries have been changed to use the database's default policy.
    
    One or more Password Policy Names were already in this database but had different settings. They have been renamed.
    

    V3.27 works fine with my database. Though moving of large groups takes lots of time and group tree expands on saving.

     
  • DrK
    DrK
    2012-04-03

    I don't think there is anything wrong with your database.

    As I said before, there is a known problem creating groups which can be circumvented.

    The 2 messages you show are not errors but warning messages. Probably because you were importing the exported entries back into the same database.

    Only Export to XML supports the new Named Password Policies. If you want to export and re-import, then I suggest that you:
    1. Export all entries and all fields of all entries to XML.
    2. Close the database (File->Close)
    3. Create a new database (with a different name so that you don't overwrite your current one) (File-New).
    4. Import all entries into this new database.

    Note: The exported file will contain all your data in clear form. You may want to use a program you can get from the web to securely erase it.

    Until the new group bug is fixed, you will still not be able to create new groups except by adding entries and specifying the new group in them or by editing existing entries.

    David

     
  • ouzo12
    ouzo12
    2012-05-03

    I get the same. I have 31 groups and 287 items. When I try to create a new group, the group name disappears after pressing OK.

    Now the strange thing is that if I repeatedly try to create the group with the same name, eventually a random entry in another group gets renamed to the name I was trying to give to the new group.

    I didn't want to take any chances so I went to the ibak from before I'd tried to add the group.

     
  • Rony Shapiro
    Rony Shapiro
    2013-01-09

    • status: pending --> closed
    • milestone: --> v1.0_(example)