#24 cpm: Depends: libcdk4 (<= 4.9.10) but it is not installable

closed-fixed
None
5
2009-03-02
2007-04-26
Peter Welter
No

Hello,

Today I tried to install cpm under debian 4.0 etch (freshly installed) while making use of your website, adding the following to /etc/apt/sources.list:

deb http://debian.harry-b.de/ unstable/

or

deb http://debian.harry-b.de/ sarge/

Both give the error:

bash# apt-get install cpm
[bla bla]

The following packages have unmet dependencies:
cpm: Depends: libcdk4 (<= 4.9.10) but it is not installable
E: Broken packages

due to the unavailability of libcdk4. IT seems that libcdk is removed from the distro.

See: http://packages.qa.debian.org/libc/libcdk.html

Regards,
Peter

Discussion

    • assigned_to: nobody --> harry_b
    • status: open --> pending
     
  • Yes, CDK4 was removed from the distribution. I am working on the CDK5 compatibility right now, hoping to get this fixed soon.

     
    • status: pending --> closed
     
  • This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • This will be fixed with released v0.25beta.

     
    • status: closed --> closed-accepted
     
    • status: closed-accepted --> closed-fixed