Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Diff of /configure.ac [0799e4] .. [d6e37a] Maximize Restore

  Switch to side-by-side view

--- a/configure.ac
+++ b/configure.ac
@@ -55,7 +55,7 @@
 changequote([,])dnl
 
 
-GIMP_REQUIRED_VERSION=2.2.0
+GIMP_REQUIRED_VERSION=2.0.0
 
 PKG_CHECK_MODULES(GIMP,
   gimp-2.0 >= $GIMP_REQUIRED_VERSION gimpui-2.0 >= $GIMP_REQUIRED_VERSION)
@@ -65,6 +65,10 @@
 
 GIMP_LIBDIR=`$PKG_CONFIG --variable=gimplibdir gimp-2.0`
 AC_SUBST(GIMP_LIBDIR)
+
+if `$PKG_CONFIG gimp-2.0 --max-version=2.0.6`; then
+  AC_DEFINE_UNQUOTED(GIMP_2_0, 1, ["defined if GIMP version is less than or equal to 2.0.6"])
+fi
 
 dnl i18n stuff
 
@@ -177,30 +181,6 @@
 fi
 
 AC_SUBST(STYLEBASE)
-
-AC_MSG_CHECKING([if GTK+ is version 2.7.0 or newer])
-if $PKG_CONFIG --atleast-version=2.7.0 gtk+-2.0; then
-  have_gtk_2_7=yes
-else
-  have_gtk_2_7=no
-fi
-AC_MSG_RESULT($have_gtk_2_7)
-
-if test "x$have_gtk_2_7" != "xyes"; then
-  CPPFLAGS="$CPPFLAGS -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
-fi
-
-AC_MSG_CHECKING([if GIMP is version 2.3.0 or newer])
-if $PKG_CONFIG --atleast-version=2.3.0 gimp-2.0; then
-  have_gimp_2_3=yes
-else
-  have_gimp_2_3=no
-fi
-AC_MSG_RESULT($have_gimp_2_3)
-
-if test "x$have_gimp_2_3" != "xyes"; then
-  CPPFLAGS="$CPPFLAGS -DGIMP_DISABLE_DEPRECATED"
-fi
 
 AC_CONFIG_FILES([
 Makefile