Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#1976 Problem installing Console in subdomains

closed-works-for-me
MDtrooper
6
2013-09-23
2013-02-19
Jose Luis Rivero
No

I have installed a pandoraFMS Console (4.0.3-170203) in a machine and redirect a subdomain to it, let's say: https:///subdomain.my-site.org.

In my pandora config.php I have the following variables:
homedir = "/var/www/pandora_console"
homeurl=""
public_url="https:///subdomain.my-site.org"

And a standard apache installation:
DocumentRoot /var/www/pandora_console
ServerName https:///subdomain.my-site.org:443

This will result in pandora console generating invalid paths for CSS and Javascript, in the form of:
....
<link rel="stylesheet" href="//include/styles/common.css" type="text/css" />
<link rel="stylesheet" href="//include/styles/menu.css" type="text/css" />
...
<script type="text/javascript" src="//include/javascript/jquery.ui.core.js"></script>
<script type="text/javascript" src="//include/javascript/jquery.ui.dialog.js"></script>
<script type="text/javascript" src="//include/javascript/jquery.ui.draggable.js"></script>

These double // will break the path and made pandorafms completely unusable.

I was search in the code a little bit and seems like the problem is inside functions_ui.php with setting homeurl to use a / when no value is given.
Any further information, please ask me.

Thanks.

Discussion

1 2 > >> (Page 1 of 2)
  • Sancho Lerena
    Sancho Lerena
    2013-03-08

    This bug is reported on 4.0.3. Please take a look on 5.0 and 4.0.3.

     
  • Thanks for your answer. When you said "take a look on 5.0 and 4.0.3" I'm understand that branch 5.0 could have the fixes in there but I'm currently using the 4.0.3 version (4.0.3-170203 to be exact) so Ididn't understand well what you mean by "having a look to 4.0.3".

    Upgrading to 5.0 it is not an option for us, at this moment. If the fix is in 5.0, is it difficult to backport? I can made a patch if you point me to relevant commit or code.

    Thanks.

     
  • MDtrooper
    MDtrooper
    2013-03-11

    Hi.

    Could you try with public_url="https://subdomain.my-site.org"?

    Because I have been testing with a Pandora 4 from the SVN and for me runs fine.

    Bye, thanks.

     
1 2 > >> (Page 1 of 2)


Anonymous


Cancel   Add attachments