pam-mysql 0.6.1 (stable) & 0.7pre2 are released!!

The latest versions of pam-mysql, which allows PAM aware applications to authenticate users through a MySQL database, are just released.

New features:
* SHA1 support (0.7pre2)
* "use_first_pass" and "try_first_pass" options for effective
use of PAM semantics. (0.7pre2)
* "use_323_passwd" option (0.6.1, 0.7pre2)

Changes:
* Changed column name handling to not escape meta
characters. Now you can specify an expression to every
XXXcolumn variable like "CONCAT(a, b, c)" (0.7pre2)
* Fixed account management code that wouldn't work
at all :-p (0.6.1, 0.7pre2)
* Included pam_mysql.spec to the tarball by default.
This enables you to make a RPM with the following
oneliner: (rpmbuild -tb pam_mysql.tar.gz).(0.6.1, 0.7pre2)
* Fixed compile failure that occurs with the old mysql_config (< 4.0.16). (0.6.1, 0.7pre2)
* Fixed compile failure on Solaris when --with-openssl is
specified to the configure script. (0.6.1, 0.7pre2)

Please grab it from
http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.1.tar.gz
http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.7pre2.tar.gz

Have fun!

Moriyoshi

Posted by Moriyoshi Koizumi 2005-09-18