Xcode

Help
shirkavand
2008-10-05
2013-04-09
  • shirkavand
    shirkavand
    2008-10-05

    Hi,

    I just download the tarball of PaintBrush2 from http://paintbrush.svn.sourceforge.net/viewvc/paintbrush/Paintbrush2/ to try this beatiful app. This is my first time trying to program over cocoaand i got some errors that dontknow how to fix, so i need some help:  After extract the files i just clickedthe "Paintbrush2.xcodeproj" file to open the project but it popup a warning asking me if i want to open the project because my version of xcode is older than the PaintBrush uses. My version of Xcode is 3.0 is there any newer version?

    Any way, i clickes "yes, open it", it open all the code but when i just try to compile, xcode throught me an error like this:

    "Internal error ocurred while creating dependency graph: ASSERTION FAILURE in /SpourceCache/DevToolsBase...."

    I do not know if the problem is caused for the xcode version i am using, or something else. Any idea?

    Regards

     
    • TheoCryst
      TheoCryst
      2009-01-21

      At the moment, Paintbrush is being developed using Xcode 3.1.  You can update your version from http://developer.apple.com.  Hopefully that will fix the error you are seeing.

      ~ Mike
      Lead Developer, Soggy Waffles