#1 pagc will not build with db 4.5

open
nobody
None
5
2008-01-24
2008-01-24
Tom Russo
No

On my linux systems I have Berkeley DB 4.5 with development headers installed. I require this for another project, and the earlier DB versions apparently can't be installed with development headers at the same time as the newer because the packages don't segregate the headers well.

pagc will not compile with this version of DB, giving an error about "DB_MPOOL_CLEAN" not being defined. A scan of the header file db.h shows that DB_MPOOL_CLEAN is not defined. Looking at another system with an older version of BDB, that macro *was* defined.

Obviously, Berkeley DB changed significantly since pagc was last released.

Discussion