Install on Gentoo

Help
Majo
2013-01-28
2014-09-17
  • Majo
    Majo
    2013-01-28

    Hi all, it is possible to install a pac manager on  Getnoo?
    Thanks

     
  • Hi!
    As far as I know, yes, it may be used! (at the very end, it is just a Perl program with some dependencies, likte Gtk2, perl modules, …)

    The only thing is install the .tar.gz file (uncompress it), and install all the required dependencies (the fastest way to discover them is by starting "pac" on the command line, and installing everything it "spits outs" ;)

    - David.

     
  • LukasH
    LukasH
    2013-06-01

    Hi,

    I was installing today PAC on Gentoo machine. On machine with Ubuntu it was working out-of-the-box, on Gentoo I managed to get it working be doing following:

    emerge -av dev-perl/yaml
    USE="perl" emerge -av dev-libs/ossp-uuid
    emerge -av dev-perl/crypt-cbc
    emerge -av dev-perl/gtk2-perl
    emerge -av dev-perl/Socket6
    emerge -av dev-perl/Net-ARP
    emerge -av dev-perl/Crypt-Rijndael
    emerge -av dev-perl/Crypt-Blowfish
    emerge -av dev-perl/Gtk2-Ex-Simple-List
    emerge -av dev-perl/gnome2-gconf
    emerge -av dev-perl/gtk2-gladexmlmerge
    emerge -av dev-perl/Expect

    cpan
    (If you are lunching cpan for a 1st time you will be asked several questions.)

    install Gnome2::Vte
    install IO::Stty

    After that download PAC as .tar.gz and exctract. In file lib/PACMain.pm add somewhere into include section this:

    use Gnome2::Vte;

    And you are done, now you can run it by using ./pac