#213 Main Window issues since 4.5.3.8

v1.0 (example)
open
None
5
2014-07-27
2014-04-09
Harald Boehmecke
No

Hi David!

I've got a problem with the last two versions...
After upgrading from 4.5.3.7 to 4.5.3.8 every time I opened a connection, the Main Window would open.

Yesterday I upgraded to 4.5.3.8.1 and the Main Window would still open after a connection has been started, but this time the Main Window was completely blank.

I tried deleting all the configuration and reinstalling PAC 4.5.3.8.1 but after re-importing the config file and restarting, the Main Window would go blank.

I am now on 4.5.3.7 and cannot upgrade because I get a blank Main Window and the Main Window will open every time I open a connection.

On 4.5.3.7 everything works fine.

Can you help me out please?

Regards,

Harald

Discussion

  • Michael Clark
    Michael Clark
    2014-04-10

    I'm getting the same blank (all white) window. If I move the .config/pac directory out of the way, it comes up and I can open a local shell or create a new connection. If I put the old directory back, it fails again. I haven't tried downgrading yet but it will probably work. Just using the terminal for a while until I can dig into debugging it better.

     
  • Timofey
    Timofey
    2014-04-11

    Hello. I got the same issue after upgrade.
    I found that PAC can't open RDP session in case RDP Windows size "Embedded in TAB".
    Other settings open new RDP window. It's not comfortable but for a first time it helps.
    So now I open SSH sessions in PAC tabs , RDP sessions in other RDP windows.

     
  • ryates
    ryates
    2014-04-14

    Ubuntu 14.04 - I get the same blank main window but only with 'Behaviour -> Start PAC: ->iconified in 'systray'" set.

    Unset that and all is well, tho you must close the window if you want it up but in the systray. Once in systray it behaves normally for me.

    BTW: 'Iconified in 'systray'' perhaps could be a sub-set of 'Start PAC at session start-up'.

     
  • Sebas
    Sebas
    2014-04-14

    Same issue here, can not open RDP when embedded in TAB. Full screen works though

     
  • Alejandro
    Alejandro
    2014-04-14

    Same issue here, blank screen when openning if 'config' 'iconified in systray' is selected. No RDP issue (for me works well embedded, please split tickets about it).

     
  • Michael Clark
    Michael Clark
    2014-04-14

    I thought I tested the "Iconified in 'systray'" option and still got the 'blank' screen but I just turned it off and I'm getting the terminal windows again now. I have to get better at testing.

     
  • I am on holiday. Sorry for The Bug... There will be a patch by the end of this week. Once again,sorry ffor this disaster... :(

     
  • LeeBo
    LeeBo
    2014-04-15

    Just reporting that 4.5.3.8.1 also gives me the blank screen. Version 4.5.3.8 works fine, however. Using Ubuntu 13.10 here.

    Thank you for the hard work, David. Looking forward to patch whenever you get a chance.

     
  • Hi all!
    Back from holidays (but still at home, with some free days still to enjoy).

    Please, check out PAC 4.5.3.9, and let me know if that solved your problems. I found it happened when PAC was starts minimized in systray.

    • David.
     
  • ryates
    ryates
    2014-04-16

    PAC 4.5.3.9 has fixed the blank window isssue when started as icon in systray.

    Thanks, enjoy those free days...

     
  • Timofey
    Timofey
    2014-04-17

    Hi. Issue still appears.

     
    Attachments
    • ryates
      ryates
      2014-04-17

      Hi,

      As Alejandro suggested, it probably is best to open another bug about this one. What was originally reported concerned the entire main window being blank and not a tab window within.

       
      • Timofey
        Timofey
        2014-04-17

        Take a look on my screenshot. it was all window of PAC is blank. I just shown small part of window. No any button,link,fields work when I tried to open RDP session with option "Embed in TAB". I had to close application PAC with another opened session windows(ssh) inside.

        OS - Ubuntu 12.04.4 LTS

         
        Last edit: Timofey 2014-04-17
        Attachments
        • ryates
          ryates
          2014-04-17

          In my case, and I assume that of the others, there was literally nothing inside the window frame. You have greyed out connections tab and others. So it is quite different to what I saw before the recent fix.

           
  • Thank you for the quick fix. Issue is now resolved.

     
  • Michael Clark
    Michael Clark
    2014-04-17

    Working perfectly for me as well. Thanks again for all you do. This is a great tool. Slowly converting all my friends on Ubuntu to it.

     
  • LeeBo
    LeeBo
    2014-04-19

    Working fine over here. Thank you, David!