Cannot Install packETH1.3 on Fedora Core2

Help
2006-03-14
2013-04-25
  • rajaperiasamy
    rajaperiasamy
    2006-03-14

    When I give 'make'to install packeth1.3, I get the following error.

    [root@localhost packETH-1.3]# make
    gcc -g -O2 -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations  -I/usr/in clude/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include  -c main.c
    In file included from /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/include/syslimits .h:7,
                     from /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/include/limits.h: 11,
                     from /usr/lib/glib/include/glibconfig.h:9,
                     from /usr/include/glib-1.2/glib.h:66,
                     from /usr/include/gtk-1.2/gdk/gdktypes.h:33,
                     from /usr/include/gtk-1.2/gdk/gdk.h:31,
                     from /usr/include/gtk-1.2/gtk/gtk.h:31,
                     from main.c:30:
    /usr/lib/gcc-lib/i386-redhat-linux/3.3.3/include/limits.h:122:75: limits.h: No s uch file or directory
    make: *** [main.o] Error 1

    Note: All the files that are mentioned are present in the filesystem.

    The gcc,gtk and glib are already installed.
    Any ideas on how to make it work.

     
    • rajaperiasamy
      rajaperiasamy
      2006-03-14

      Also notice that i have the following rpms installed already

      [root@localhost root]# rpm -qa gtk*
      gtk2-2.4.0-1
      gtksourceview-1.0.0-2
      gtkspell-2.0.4-4.1
      gtkhtml3-3.0.10-1
      gtk2-devel-2.4.0-1
      gtk+-devel-1.2.10-29.1.1
      gtk+-1.2.10-29.1.1
      gtk2-engines-2.2.0-5
      gtk-engines-0.12-3.0.1
      gtk-doc-1.2-1
      gtkhtml2-2.6.0-1
      gtkhtml-devel-1.1.9-8
      [root@localhost root]# rpm -qa glib*
      glib-devel-1.2.10-12.1.1
      glibc-common-2.3.3-27
      glib2-2.4.0-1
      glib2-devel-2.4.0-1
      glibc-2.3.3-27
      glib-1.2.10-12.1.1
      [root@localhost root]#
      [root@localhost root]# rpm -qa gcc*
      gcc-c++-3.3.3-7
      gcc-objc-3.3.3-7
      gcc-3.3.3-7
      gcc-g77-3.3.3-7
      gcc-gnat-3.3.3-7
      gcc-java-3.3.3-7
      [root@localhost root]#

       
    • Miha Jemec
      Miha Jemec
      2006-03-22

      HI!

      With the standard installation of FC2 with development libraries and packages installed I never had problems like yours so I can not give you any advice here. Could be that you changed some common files after the installation which are causing problems right know but this is only my assumption.

      My expirience is that packETH can be installed without any problems on any Fedora version, the only thing needed are development packages.

      Regards, Miha