Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

PackETH won't install on RH9

Help
Daichinger
2007-09-04
2013-04-25
  • Daichinger
    Daichinger
    2007-09-04

    Hi,

    I am new to using Linux so it may just be me but I don't think it is. PackETH doesn't install properly on my RH9. Here is some of the error messages i get.

    [root@localhost packETH-1.4.1]# make
    gcc -g -O2 -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations
    -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
    -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
    -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -c interface.c
    interface.c: In function `create_window1':
    interface.c:890: warning: implicit declaration of function `gtk_tool_item_new'
    interface.c: In function `create_fileselection1':
    interface.c:7844: warning: implicit declaration of function
    `gtk_file_chooser_dialog_new'
    interface.c:7844: `GTK_FILE_CHOOSER_ACTION_OPEN' undeclared (first use
    in this function)
    interface.c:7844: (Each undeclared identifier is reported only once
    interface.c:7844: for each function it appears in.)
    interface.c:7844: warning: assignment makes pointer from integer without a cast
    interface.c: In function `create_fileselection2':
    interface.c:7895: `GTK_FILE_CHOOSER_ACTION_SAVE' undeclared (first use
    in this function)
    interface.c:7895: warning: assignment makes pointer from integer without a cast
    interface.c: In function `create_fileselection3':
    interface.c:7946: `GTK_FILE_CHOOSER_ACTION_OPEN' undeclared (first use
    in this function)
    interface.c:7946: warning: assignment makes pointer from integer without a cast
    make: *** [interface.o] Error 1

    Here are the libraries i have:
    [root@localhost root]# rpm -qa gtk*
    gtk+-1.2.10-25
    gtk2-2.2.1-4
    gtk-engines-0.11-16
    gtk+-devel-1.2.10-25
    gtkhtml-devel-1.1.8-5
    gtk2-devel-2.2.1-4
    gtkglarea-1.2.2-16
    gtkhtml-1.1.8-5
    gtk2-engines-2.2.0-2
    gtk-doc-0.10-4
    gtkhtml2-2.2.0-5
    gtkhtml2-devel-2.2.0-5
    gtkam-0.1.7-3
    gtkam-gimp-0.1.7-3
    [root@localhost root]# rpm -qa glib*
    glib-1.2.10-10
    glibc-devel-2.3.2-11.9
    glib2-devel-2.2.1-1
    glibc-debug-2.3.2-11.9
    glibc-common-2.3.2-11.9
    glib2-2.2.1-1
    glibc-kernheaders-2.4-8.10
    glibc-profile-2.3.2-11.9
    glibc-utils-2.3.2-11.9
    glibc-2.3.2-11.9
    glib-devel-1.2.10-10

    Any ideas?

     
    • Miha Jemec
      Miha Jemec
      2007-09-12

      Sorry no ideas, could be that RH9 uses some special gtk or glib libraries? Try to look on the web because I think this is not packETH related.

      Regards, Miha

       
    • Daichinger
      Daichinger
      2007-09-12

      What are the gtk and glib libraries that you use? The versions?