Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Compilation error on RHEL6

Help
2011-07-11
2013-06-12
  • Sandeep Rathan
    Sandeep Rathan
    2011-07-11

    Hi,

    Has anyone complied Ovaldi.5.9.1 on RHEL 6 (Fully patched) ? Following is the error when we tried to compile.

    g++  -Wall -O -DLINUX -I/usr/local/include -I/usr/include -I../../src/linux -I../../src -I../../src/probes/unix -I../../src/probes/linux -I../../src/probes/independent -DPACKAGE_RPM  -c -o ../../src/Main.o ../../src/Main.cpp
    In file included from ../../src/linux/ProbeFactory.h:50,
                     from ../../src/linux/ObjectCollector.h:36,
                     from ../../src/linux/DataCollector.h:35,
                     from ../../src/Main.h:67,
                     from ../../src/Main.cpp:31:
    ../../src/probes/linux/RPMInfoProbe.h:112: error: ‘int_32’ has not been declared
    ../../src/probes/linux/RPMInfoProbe.h:113: error: ‘int_32’ has not been declared
    ../../src/probes/linux/RPMInfoProbe.h:114: error: ‘int_32’ does not name a type
    make: ***  Error 1

    We know that this compilation error can be fixed by degrading rpm packages from version 4.8 to 4.4.  What we are interested in, Is there any way we can fix this error with rpm 4.8 packages ?

    Regards,
    Sandeep.

     
  • Sandeep Rathan
    Sandeep Rathan
    2011-07-27

    Instructions preset @ http://sourceforge.net/apps/mediawiki/ovaldi/index.php?title=Build_notes  definitely helped compiling on RHEL 6. But when tried to execute rpminfo test content it report's an error

    ===============================================================
    Command line output


    ./ovaldi -m -n -o linux-def_rpminfo_test.xml


    OVAL Definition Interpreter
    Version: 5.9 Build: 1
    Build date: Jul 26 2011 13:13:38
    Copyright (C) 2002-2011 - The MITRE Corporation


    Start Time: Tue Jul 26 13:19:24 2011

    ** parsing linux-def_rpminfo_test.xml file.
        - validating xml schema.
    ** checking schema version
         - Schema version - 5.9
    ** running Schematron validation on linux-def_rpminfo_test.xml
         - Schematron validation succeeded
    ** creating a new OVAL System Characteristics file.
    ** gathering data for the OVAL definitions.
          Collecting object: oval:org.mitre.oval.test:obj:251
    Freeing read locks for locker 0x1b6: 3091/3079162400
    Freeing read locks for locker 0x1b7: 3091/3079162400
    Freeing read locks for locker 0x1b8: 3091/3079162400
    FINISHED                      
    ** saving data model to system-characteristics.xml.
    ** running the OVAL Definition analysis.
          Analyzing definition:  FINISHED                      
    ** applying directives to OVAL results.
    ** OVAL definition results.

        OVAL Id                                 Result
        -------------------------------------
        oval:org.mitre.oval.test:def:121        error         
        -------------------------------------

    ** finished evaluating OVAL definitions.

    ** saving OVAL results to results.xml.
    ** running OVAL Results xsl: /usr/share/ovaldi/results_to_html.xsl.

    -----------------------------------

    system-characteristics.xml had following error

        <object flag="error" id="oval:org.mitre.oval.test:obj:236" version="1">
          <oval-sc:message level="fatal">Error running rpm query in child process: blah: -q: unknown option
    </oval-sc:message>

     
  • Stjepan Gros
    Stjepan Gros
    2011-10-30

    I don't know if you already resolved that error with unknown -q option, but info for others. The problem is that poptOptions array didn't have appropriate initialization value. I made a patch that allows ovaldi to be compiled on centos 6, which I suppose will also allow it to be compiled on RHEL6. Additional info you can find here:

    http://sgros.blogspot.com/2011/10/compiling-ovaldi-for-centos-6.html