running on computer without .net framework

Help
evilace
2013-04-03
2013-06-12
  • evilace
    evilace
    2013-04-03

    I have successful built the project and run it on my own computer, but when I ran it on other computer, it ask me to install .Net framework, is it possible to build a executable which could run without installing .Net Framework?

     
  • evilace
    evilace
    2013-04-18

    Thank you, djhaynes. I successful run ovaldi 5.10 on Win2k8 without .NetFramework. But Here comes a new problem, when I run a  oval def,  ovaldi reply  "Message: Unknown element 'family_test" ,  Below is the xml def:

    <family_test id="oval:org.mitre.oval:tst:99" version="1" comment="the installed operating system is part of the Microsoft Windows family" check_existence="at_least_one_exists" check="only one" xmlns="http://oval.mitre.org/XMLSchema/oval-definitions-5#independent">
          <object object_ref="oval:org.mitre.oval:obj:99"/>
          <state state_ref="oval:org.mitre.oval:ste:99"/>
        </family_test>

    I can successful run  a win7 oval  definition with the element "family_test", is there something wrong ?

     
  • Hi evilace,
    That warning message is consistent with the Interpreter not being able to locate the schema file for the associated message. In this case, could you verify that you have a copy of the independent-definitions-schema.xsd file in your xml directory? If you are not specifying one with the "-a" flag then it should be in a subdirectory near the OVALDI executable.

    One other option would be if somehow the schema file exists but the schema location was not specified in the "xsi:schemaLocation" attribute of the root oval_definitions element. Could you make sure that attribute exists and contains  "http://oval.mitre.org/XMLSchema/oval-definitions-5#independent independent-definitions-schema.xsd " among the locations to the other referenced files?

    Thanks,
    David Rothenberg