otto with ogg

  • knoppsie

    I have installed follow programs:
    - apache2, version 2.0.49
    - php4, version 4.3.4
    - mysql, version 4.0.18

    I have configured apache2.
    I have create database otto.
    I have called schema.sql.
    I have called webuser.sql.
    I have copied otto.con.dist to otto.conf.
    I have changed user apache and group apache to wwwrun and www.
    I have changed home to http://localhost/otto.
    I have changed MusicRoot to /ogg.

    I start browser and call http://localhost/otto.
    The browser show me the web interface of OTTO audio jukebox. The message says: no songs in queue.

    All my songs are in directorys /ogg/interpreter/name of the album.
    All my songs codet in ogg format.
    Now I will insert the infrormation about my music in the database. Therefore I call /usr/local/otto/bin/otto load. The program answer: "Died at /usr/local/otto/lib/OttO/ at line 391
    I checked the database otto in phpMyAdmin. I have no item in the table database.

    I had read in forum that otto can play ogg-files.
    What mut I do to load the database?
    What mut I do to play ogg-files with otto.

    • Rick Parker
      Rick Parker

      When you say you have no item in the table database do you mean there is no songs table?  It looks like your loader dies when trying to do
      select * from songs
      If you don't have any tables created at all, try to rerun the schema.sql, it's supposed to create them.

    • Rick Parker
      Rick Parker

      By the way, this is what you should have in the otto database...

      mysql> show tables;
      | Tables_in_otto |
      | albums         |
      | channels       |
      | fileunder      |
      | fileundermap   |
      | listelements   |
      | listenerlog    |
      | listenermap    |
      | lists          |
      | propernamemap  |
      | queue          |
      | seealso        |
      | songs          |
      | stats          |
      | users          |
      14 rows in set (0.00 sec)

    • knoppsie

      Hello Rick,

      I checked the tables. I have all tables which you listed.
      I have convert on ogg-file into wav and then into mp3.
      This mp3-file is in the same directory like many other ogg-files. Then I made /usr/local/otto/bin/otto load.
      Otto inserted only this mp3 file. He ignores the ogg-files.

      I can see the information about the one mp3.file in the table song. Also I can see the name of the album in the table album.

      • Rick Parker
        Rick Parker

        So does it ignore the ogg files or give an error?
        If it's just ignoring them, it could be that you need to set it in your otto.conf file to use .ogg files, it's probably got .mp3 and .MP3 there only now.

    • knoppsie

      Hello Rick,

      thank you for your help. otto ignors the ogg files.
      I have set otto.conf. I changed all mpg123 to ogg123. Then I could add all 530 songs.

      Now I have another problem. The items for testchannel in otto.conf are enabled and the lines for channel 1 are disabled.
      I will start otto deamon with /usr/local/otto/bin/otto start. The deamon starts
      Then I stop the deamons. I disables the lines for testchannel and enables the lines for channel 1.
      Then I call /usr/local/otto/bin/otto start.
      But the deamon doesn't start. In /usr/local/otto/var/otto.log I can read a new item.
      Can't call method "play" on an undefined value at /usr/local/otto/lib/Otto/ on line 107.
      In line 107 of I read:
      my $result = $method->play(file => $file, metadata => $metadata);
      What is wrong?