#53 Build dependency on 10.2.8 SDK is mandatory

open
nobody
None
5
2007-07-21
2007-07-21
David Corking
No

When building version 2.1 from source with the standard Xcode and macports distribution on (for example)
Mac OS X 10.4.10, Intel Core 2 Duo
Mac OS X 10.4.9, dual G5
we see the following error message:

Checking Dependencies... error: There is no SDK at specified SDKROOT_ppc path '/Developer/SDKs/MacOSX10.2.8.sdk'
** BUILD FAILED **

If someone can offer a patch that makes 10.2.8 SDK optional (where appropriate), it would make it easier on macports users and others who build from source on Tiger.

See also downstream ticket:
http://trac.macosforge.org/projects/macports/ticket/12077

Discussion