Anyone using this with the Snow Leopard?

Help
Jason
2009-07-21
2013-04-22
  • Jason
    Jason
    2009-07-21

    Anyone know if the drivers works with SL?  Need a USB->Serial adapter and running the SL dev builds on my system.

     
    • umm, it works, but unfortunately, it only works in 32-bit mode...
      have my pharos gps-360 and i am getting data in 32-bit mode. device detected as a usb-serial adapter that is not configured, but in 64-bit mode, the device is not detected. if the developer could update the kext with a 64-bit version it would be awesome! :)

       
  • Vivek Khera
    Vivek Khera
    2009-11-03

    Curious… last week I was able to connect over my serial port to my firewall device, but tonight (when I need it for an upgrade) the /dev/tty.PL2303 is not showing up.

    I've removed and re-installed the driver twice.  Forced it to load via kldload.  It seems to unload itself after a few minutes, as kldstat shows it  is there initially, but then it disappears.

    The console repeatedly reports:

    USBF: 696.802 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 4 of hub @ location: 0xfa400000)

    when the serial dongle is plugged in.

    I'm not sure what I did to make it stop working between last week and today.

     
  • I'm using this on a Macbook Pro 15" with 32-bit 10.6.4, and this dongle:

    http://www.amazon.com/RS232-Serial-Cable-Adapter-Converter/dp/tech-data/B0034JG828/ref=de_a_smtd

    it works for a while, at least in Zterm, and then locks up when receiving a long burst of input.  I'm wondering if there's a race condition on draining a FIFO that causes it to think that the FIFO is empty when it's really full (i.e. buffer wrap-around).

    Would be nice if someone rebuild it for 10.6.4.

     
  • I'm running it on 10.6.5 and still experiencing issues.  Indeed, I see in dmesg:

    nl_bjaelectronics_driver_PL2303(0x7751500)::dequeueDataGated - INTERRUPTED
    nl_bjaelectronics_driver_PL2303(0x7751500)::dequeueDataGated - INTERRUPTED
    nl_bjaelectronics_driver_PL2303(0x7751500)::dequeueDataGated - INTERRUPTED
    nl_bjaelectronics_driver_PL2303(0x7751500)::dequeueDataGated - INTERRUPTED
    nl_bjaelectronics_driver_PL2303(0x7751500)::dequeueDataGated - INTERRUPTED
    nl_bjaelectronics_driver_PL2303(0x7751500)::dequeueDataGated - INTERRUPTED
    nl_bjaelectronics_driver_PL2303(0x7751500)::dequeueDataGated - INTERRUPTED
    nl_bjaelectronics_driver_PL2303(0x7751500)::dequeueDataGated - INTERRUPTED

    Joeren: can you please rebuild this for 10.6.5 on the off-chance that this fixes the issue?

    Thanks.