#53 norwegian characters ÆØÅ not displayed properly

closed
None
5
2008-04-01
2007-12-11
AlCapone
No

SITUATION IDENTIFIED IN:
OSF 2.0.1.0

REPRODUCTION ENVIRONMENT:
Win XP pro, English. osCommerce webshop.

PROBLEM DESCRIPTION:
After importing items/status/orders, any words containing norwegian letters ÆØÅ are not displayed correctly.

STEPS TO BE FOLLOWED:
take a look at:
http://www.osfinancials.org/modules.php?op=modload&name=phpbb2&file=viewtopic.php&t=906&start=0&postdays=0&postorder=asc&highlight=&sid=6a8fa30f68ecddf790b6c907f0e43823

ADDITIONAL COMMENTS:

This makes osF useless to norwegian/danish/swedish users, and propably dangerous to update products using it, as product description would be damaged.

Discussion

  • AlCapone
    AlCapone
    2007-12-14

    Logged In: YES
    user_id=910958
    Originator: YES

    please look at the forum link.
    it is the osfinancials.php that returns strange characters.

     
  • Logged In: YES
    user_id=1017140
    Originator: NO

    The changes need to be doen in the PHP (at least for start) and i dont know how to do that. So im moving this bug to the feature request.

     
  • Domé Giuliano
    Domé Giuliano
    2008-04-01

    Logged In: YES
    user_id=1248614
    Originator: NO

    In the latest versions this is implemented.
    Also see this osC contribution for it, if you use an older version of osF: http://www.oscommerce.com/community/contributions,5697/category,all/search,osfinancials

     
  • Domé Giuliano
    Domé Giuliano
    2008-04-01

    • assigned_to: nobody --> cdgo
    • status: open --> closed