fgsd throughing buffer overflow error

2011-06-08
2013-05-28
  • SharjeelHKh
    SharjeelHKh
    2011-06-08

    Hi all,

    I m new in community. I m using ubuntu 10.04.
    I have install flightgear Scenery designer(fgsd) and it executed successfully, but during working on it I selected any option of it and fgsd crashed. After that it is not getting execute. Throwing following error on console.

    buffer overflow detected ***: fgsd terminated
    *******************************************************
    /lib/tls/i686/cmov/libc.so.6(__fortify_fail+0x50)
    /lib/tls/i686/cmov/libc.so.6(+0xe12ca)
    /lib/tls/i686/cmov/libc.so.6(+0xe0a0
    /lib/tls/i686/cmov/libc.so.6(_IO_default_xsputn+0x9e)
    /lib/tls/i686/cmov/libc.so.6(_IO_vfprintf+0xe24)
    /lib/tls/i686/cmov/libc.so.6(__vsprintf_chk+0xad)
    /lib/tls/i686/cmov/libc.so.6(__sprintf_chk+0x2d)
    /usr/local/lib/libflu.so(_ZN12Flu_Progress4drawEv+0xd1)
    /usr/lib/libfltk.so.1.1(_ZNK8Fl_Group10draw_childER9Fl_Widg et+0x64)
    /usr/lib/libfltk.so.1.1(_ZN8Fl_Group13draw_childrenEv+0x5f)
    /usr/lib/libfltk.so.1.1(_ZN8Fl_Group4drawEv+0x3a)
    /usr/lib/libfltk.so.1.1(_ZN9Fl_Window4drawEv+0x5f)
    /usr/lib/libfltk.so.1.1(_ZN9Fl_Window5flushEv+0x42)
    /usr/lib/libfltk.so.1.1(_ZN2Fl5flushEv+0xab)
    /usr/lib/libfltk.so.1.1(_ZN2Fl4waitEd+0x16c)
    /usr/lib/libfltk.so.1.1(_ZN2Fl5checkEv+0x1c)
    fgsd
    fgsd
    fgsd
    fgsd

    What possibly cause of this problem??, Any suggestion
    SharjeelHKh is offline   Reply With Quote

     
  • Clifford Heath
    Clifford Heath
    2011-06-08

    You've asked in the wrong place. The orm project is a fact-based modeling design tool which plugs in to Visual Studio, nothing to do with flightgear scenery designer.