Login Session Issue

Support
Dasha
2007-04-26
2013-06-05
  • Dasha
    Dasha
    2007-04-26

    This is the message from OrangeHRM users:

    After logging into the application, and then you click the Logout button, whenever you subsequently try to log in again, it won't let you log in and reports the following at the top of the page:

    Your session expired because you were inactive. Please re-login.

    Seems like there is logical error with the cookies somewhere, as surely if I've logged out I should be able to log back in at anytime.

    OrangeHRM v2.0.2 on IIS6 and PHP5.

     
    • This doesn't happen if you used OrangeHRM on Apache and PHP5. This is a bug in IIS. Please report this issue to creators of IIS or switch to the most used Web Server; Apache HTTP Server.

      mohnajith

       
      • What a horrible answer. Firefox would never have taken off if people held that same attitude, as most people use IE (simply by default).

        I'm having the same issue. I haven't had this issue with ANY OTHER PHP application under IIS.

        I will try to find a solution and report my findings.

        thebeaz

         
    • mrahman, I hope you haven't given up on this interesting product yet due to the unhelpful comment. It is not a bug in IIS, it is a permissions issue.

      In my situation the website is not accessible outside of the company's intranet and since the application uses its own authentication system, the following worked:

      In IIS, navigate to the root install of the Orangehrm software...
      Code:

      Example: Websites -> Default Websites -> Orangehrm

      Right-click the folder and choose "Properties". Choose the "Directory Security Tab". Click "Edit" under "Authentication and access control". Make sure "Enable Anonymous Access" is checked, then enter credentials for an account with ADMINISTRATIVE privileges on that machine.

      Once I applied those settings, Orangehrm started working again.

      If you ever see this, let me know if that works out for you.

       
  • Mafaz Mazeen
    Mafaz Mazeen
    2009-12-02

    Hi thebeaz,

    I have a somewhat similar problem, the only difference being that where mrahman's issue occurs only after re-logging in, mine occurs on every login attempt. You can visit http://myschool360.net/phpapps/orangehrm/ and enter 'demo', 'demo' for username and password respectively.

    Luckily, I have a dedicated server so getting to the IIS control panel was not an issue for me. i followed ur advice but nothing changed. i still can't login. i've verified that the user does exist in the database and such…

    Do you have any other ideas?

     
  • Mafaz Mazeen
    Mafaz Mazeen
    2009-12-23

    All,

    I had the same issue and I am on IIS as well. I was able to rectify the solution by adding an exit as below
    ie line no 150

    header("Location: ./index.php");
    exit;

     
  • Mafaz Mazeen
    Mafaz Mazeen
    2010-03-09

    I moved application OrangeHRM v2.5.0.2 on a new web server and i have the same problem.

    Server 1 : apache
    Serveur 2 : Mysql

    MySQL version 5.0.51a-community
    Apache version 2.2.11
    PHP version 5.2.8

    have you found a fix ?

     
  • It works !!
    I appreciate your help.

     
  • hi. . .
    thanks for that Information. ..
    Nice to post this site i cought some datails about this. .

     
  • Same happy with me to. It's as I think Unicode Support Problems…
    But I use it on Apache. I get ride of it when in PHP .INI turned on SESSIONS.USE_COOKIES = 1

    The part of problem is invalid language file and|or language settings in browser. ANd some times date differences betwen server & you. CHeck them! :idea:

     
  • Thanks for the hint bishop!

    It worked!!

     
  • This solution solves my log in problem and now I was able to rectify the solution

     
  • NICE Information.

     
  •     I found the solution to solve my login problem.

        I added this parameter in php.ini

        suhosin.session.encrypt = off

    awesome man, it is really work. Thank you very much.