#18 Upgrade to libpng 1.2.39

closed-later
Cosmin Truta
None
5
2014-08-29
2009-09-09
Ernst de Haan
No

The current version of OptiPNG (0.6.3 as of Sept. 9, 2009) is based on libpng 1.2.36. However, the current version of libpng is already 1.2.39. Perhaps it should be upgraded. See: http://www.libpng.org/pub/png/libpng.html

Discussion

  • Cosmin Truta
    Cosmin Truta
    2009-09-13

    Thanks for the report. BTW, libpng 1.2.40 is already out, and libpng 1.4.0 is just around the corner.
    As a general rule, every new OptiPNG release has the latest libpng. On the other hand, there is no need to make a new OptiPNG release with every libpng release, unless the new libpng release contains a functionality enhancement or a critical fix that affects OptiPNG. Moreover of the past libpng updates have left OptiPNG unaffected however, because OptiPNG bypasses a lot of libpng functionality and replaces it with its own processing.
    For this reason, there is no need to make a new update just for libpng 1.2.40. I am more or less half-way between the existing version 0.6.3 and the next one, 0.6.4. When the new version comes out, it will have the latest and greatest libpng, as usual.

     
  • Cosmin Truta
    Cosmin Truta
    2009-09-13

    • assigned_to: nobody --> cosmin
    • status: open --> pending-later
     
  • This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
    • status: pending-later --> closed-later