While retrieving thread level oprofiling data I am facing a problem.


I ran the oprofile with the following configuration “opcontrol --separate=all”.

[ I also tried with “opcontrol –separate=thread” option ]


Then, I did dump the data using “opcontrol –dump” option after running my application.


When I try retrieving the data from the logs using

“opreport –l > <file_name>” I find the following error.


# opreport -l > file_name

opreport error: Already displaying results for parameter tgid with values:

tgid:0,tgid:5,tgid:110,tgid:120,tgid:1140, and 50 more,

which conflicts with parameter tid.

Suggestion: specify tgid: or --merge tgid


Then I did try with # opreport –merge=all –l > <file_name>.

It did generate a log file but I couldn’t find any thread level usage details. All I could find was

The data in the below format.



samples  %        app name                 symbol name




Any inputs on what I am missing here to retrieve the thread level details ?


Please reply ASAP to me only.